<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><link rel="shortcut icon" href="https://www.mdislander.com/wp-content/themes/origmag-ea/images/mid_favicon.ico"><link href="https://fonts.googleapis.com/css?family=Vollkorn:400,400i,700,700i" rel="stylesheet"> <script data-cfasync="false" type="text/javascript" src="https://cdn.broadstreetads.com/init.js"></script> <script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;service=onstop&amp;v=0"></script> <!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ --><title>Letter to Editor: We can do better - Mount Desert Islander</title><meta name="description" content="To the Editor: On Monday at the United Nations, Governor Janet Mills pledged that Maine will have a carbon-neutral economy by 2045. And she signed an"/><link rel="canonical" href="https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Letter to Editor: We can do better - Mount Desert Islander" /><meta property="og:description" content="To the Editor: On Monday at the United Nations, Governor Janet Mills pledged that Maine will have a carbon-neutral economy by 2045. And she signed an" /><meta property="og:url" content="https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better" /><meta property="og:site_name" content="Mount Desert Islander" /><meta property="article:publisher" content="https://www.facebook.com/mdislander/" /><meta property="article:section" content="Opinion" /><meta property="article:published_time" content="2019-09-27T10:10:12+00:00" /><meta property="article:modified_time" content="2019-09-24T20:07:14+00:00" /><meta property="og:updated_time" content="2019-09-24T20:07:14+00:00" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.mdislander.com/#organization","name":"Mount Desert Islander","url":"https://www.mdislander.com/","sameAs":["https://www.facebook.com/mdislander/","https://www.linkedin.com/company/mount-desert-islander","https://www.youtube.com/channel/UCvRkHCLc-51mSo0CTfemKmw","https://twitter.com/TheMDIslander"],"logo":{"@type":"ImageObject","@id":"https://www.mdislander.com/#logo","url":"https://www.mdislander.com/wp-content/uploads/sites/5/2016/02/fbIslander_teal.jpg","width":1200,"height":1200,"caption":"Mount Desert Islander"},"image":{"@id":"https://www.mdislander.com/#logo"}},{"@type":"WebSite","@id":"https://www.mdislander.com/#website","url":"https://www.mdislander.com/","name":"Mount Desert Islander","publisher":{"@id":"https://www.mdislander.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.mdislander.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better#webpage","url":"https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better","inLanguage":"en-US","name":"Letter to Editor: We can do better - Mount Desert Islander","isPartOf":{"@id":"https://www.mdislander.com/#website"},"datePublished":"2019-09-27T10:10:12+00:00","dateModified":"2019-09-24T20:07:14+00:00","description":"To the Editor: On Monday at the United Nations, Governor Janet Mills pledged that Maine will have a carbon-neutral economy by 2045. And she signed an"},{"@type":"Article","@id":"https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better#article","isPartOf":{"@id":"https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better#webpage"},"author":{"@id":"https://www.mdislander.com/#/schema/person/66df21384f3e8686fd252bc7c8390c84"},"headline":"Letter to Editor: We can do better","datePublished":"2019-09-27T10:10:12+00:00","dateModified":"2019-09-24T20:07:14+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better#webpage"},"publisher":{"@id":"https://www.mdislander.com/#organization"},"articleSection":"Letters to the editor,Opinion"},{"@type":["Person"],"@id":"https://www.mdislander.com/#/schema/person/66df21384f3e8686fd252bc7c8390c84","name":"Guest","image":{"@type":"ImageObject","@id":"https://www.mdislander.com/#authorlogo","url":"https://secure.gravatar.com/avatar/42aca01709e48eaba90ce4df8cc48ed6?s=96&d=blank&r=g","caption":"Guest"},"sameAs":[]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Feed" href="https://www.mdislander.com/feed" /><link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Comments Feed" href="https://www.mdislander.com/comments/feed" /><link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Letter to Editor: We can do better Comments Feed" href="https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better/feed" /><link rel='stylesheet' id='yarppWidgetCss-css'  href='https://www.mdislander.com/wp-content/plugins/yet-another-related-posts-plugin/style/yarppWidgetCss.min.css' type='text/css' media='all' /><link rel='stylesheet' id='aqpb-view-css-css'  href='https://www.mdislander.com/wp-content/themes/original/page-builder/assets/css/aqpb-view-css.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://www.mdislander.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://www.mdislander.com/wp-content/plugins/column-shortcodes//assets/css/cpsh-shortcodes.min.css' type='text/css' media='all' /><link rel='stylesheet' id='genericons-css'  href='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/css/genericons/genericons.min.css' type='text/css' media='all' /><link rel='stylesheet' id='ts_fab_css-css'  href='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/css/ts_fab_css.min.css' type='text/css' media='all' /><link rel='stylesheet' id='zsfw-style-css'  href='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/zsfw-style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='zsfw-slider-style-css'  href='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/zsfw-slider-style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='Roboto-Slab-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab&#038;ver=5.2.3' type='text/css' media='all' /><link rel='stylesheet' id='Roboto-Condensed-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed&#038;ver=5.2.3' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css'  href='https://www.mdislander.com/wp-content/themes/original/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='weather-icon-css'  href='https://www.mdislander.com/wp-content/themes/original/css/weather-icons.min.css' type='text/css' media='all' /><link rel='stylesheet' id='flexslider-css'  href='https://www.mdislander.com/wp-content/themes/original/css/flexslider.min.css' type='text/css' media='all' /><link rel='stylesheet' id='flexslider-tab-css'  href='https://www.mdislander.com/wp-content/themes/original/css/flexslider-tab.min.css' type='text/css' media='all' /><link rel='stylesheet' id='superfish-css'  href='https://www.mdislander.com/wp-content/themes/original/css/superfish.min.css' type='text/css' media='all' /><link rel='stylesheet' id='framework-css'  href='https://www.mdislander.com/wp-content/themes/original/css/framework.min.css' type='text/css' media='all' /><link rel='stylesheet' id='style-css'  href='https://www.mdislander.com/wp-content/themes/origmag-mdi/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='print-css'  href='https://www.mdislander.com/wp-content/themes/original/css/print.min.css' type='text/css' media='print' /> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/ts_fab_js.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/zsfw-script.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/zsfw-slider-script.min.js'></script> <link rel='https://api.w.org/' href='https://www.mdislander.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mdislander.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mdislander.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.mdislander.com/?p=78135' /><link rel="alternate" type="application/json+oembed" href="https://www.mdislander.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mdislander.com%2Fopinions%2Fletter-to-editor-we-can-do-better" /><link rel="alternate" type="text/xml+oembed" href="https://www.mdislander.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mdislander.com%2Fopinions%2Fletter-to-editor-we-can-do-better&#038;format=xml" /><style>.ts-fab-wrapper .ts-fab-list li a { background-color:#e9e9e9; border: 1px solid #e9e9e9; color: #333; } .ts-fab-wrapper .ts-fab-list li.active a { background-color: #333; border: 1px solid #333; color: #fff; }.ts-fab-wrapper .ts-fab-tab.visible-tab { background-color: #f9f9f9; border: 2px solid #333; color: #555; }</style> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-55634975-4', 'auto');
			
			ga('send', 'pageview');</script> <style type="text/css">body{ background-color: #eeeeee}header#masthead .prl-header-logo,button, input[type=submit], input[type=button], a.prl-button,.prl-badge,.page_navi li.current span,.prl-accordion section.active a.head,.prl-nav-dropdown a:hover, .widget_newsletter { background-color:#00829b;}a,.prl-block-title, .prl-block-title a, .prl-archive-title,.prl-archive-title a,#footer .prl-block-title a,.comment-reply-title,#footer .prl-block-title,.twitter_widget a,.sf-menu > li.current-menu-item > a,.sf-menu > li.current_page_item > a,.sf-menu > li.current-menu-ancestor > a,.sf-menu > li.current-menu-parent > a, .sf-menu > li:hover > a,.sf-menu > li.sfHover > a { color:#00829b;}.page_navi li.current span, #sliderTab .slider_content .prl-article-meta{ border-color:#00829b;}h1,h2,h3,h4,h5,h6{font-family: "Roboto Condensed", Arial, Helvetica, sans-serif;}div.eai-scores {
padding-left: 20px;
padding-right: 20px;
}

div.eai-scores ul {
list-style: none;
padding-left: 0px;
padding-bottom: 4px;
font-size: .9em;
}

div.eai-scores li {
padding-left: 11px;
font-weight: bold;
font-size: 1.2em;
}

div.eai-scores p {
padding-bottom: 0px;
margin-bottom: 2px;
color: teal;
}

div.eai-scores h3.prl-article-title {
display: none;
}</style><meta name="thumbnail" content="https://www.mdislander.com/wp-content/themes/origmag-mdi/images/ogi-mdi.jpg"><meta property="og:image" content="https://www.mdislander.com/wp-content/themes/origmag-mdi/images/ogi-mdi.jpg"></head><body class="post-template-default single single-post postid-78135 single-format-standard site-boxed"><div id="topbar"></div><div class="site-wrapper"> <!--<div class="prl-container">--><header id="masthead" class="clearfix"><div class="prl-container"><div class="prl-nav-flip-top hidden-tablet"><div id="search_form-top" class="nav_search"><form class="prl-search" action="https://www.mdislander.com"> <input type="text" id="s" name="s" value="" placeholder="&#xF002;" class="nav_search_input" /></form></div></div><nav id="topnav" class="hidden-tablet"><div class="nav-wrapper clearfix"><ul id="top-menu" class="sf-menu eai-menu"><li id="menu-item-1574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1574"><a target="_blank" rel="noopener noreferrer" href="http://www.downeastmaine.com/classifieds/helpwanted/">Jobs</a></li><li id="menu-item-1575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1575"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li><li id="menu-item-1576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1576"><a target="_blank" rel="noopener noreferrer" href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li><li id="menu-item-52385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52385"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li><li id="menu-item-23064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23064"><a href="http://www.acadiavisitor.com/">Acadia Visitor</a></li><li id="menu-item-31935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31935"><a href="https://mountdesertislander-me.newsmemory.com">Digital Edition</a></li><li id="menu-item-57478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57478"><a href="https://www.ellsworthamericaninc.com/contact-us/contact-advertising/">Advertise</a></li></ul></div></nav></div><div class="prl-container top-header"><div class="masthead-bg clearfix"><div class="prl-header-logo"><a href="https://www.mdislander.com" title="Mount Desert Islander"><img src="https://www.mdislander.com/wp-content/uploads/sites/5/2014/09/islander_logo_teal.png" alt="Mount Desert Islander" /></a></div><div class="prl-header-mid"> <span class="prl-header-time"><a href="https://www.downeastmaine.com/calendar/events/today/"><i class="fa fa-calendar"></i>Friday - Sep 27, 2019</a></span><ul class="ea-technav-login ea-leaky-login"><li><a id="ta_account_button" onclick="ta_account()" >~</a></li></ul></div><div class="prl-header-social"> <a href="https://www.facebook.com/mdislander" class="fa fa-facebook" title="Facebook" target="_blank"></a> <a href="https://www.youtube.com/user/mountdesertislander" class="youtube-pic" title="Youtube"><img src="https://www.mdislander.com/wp-content/themes/origmag-mdi/images/youtube.jpg"></a></div><!-- end of header social --></div></header><nav id="nav" class="prl-navbar" role="navigation"><div class="prl-container"><div class="nav-wrapper clearfix centered-menu"><ul id="sf-menu" class="sf-menu"><li id="menu-item-35813" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-35813"><a href="https://www.mdislander.com">Home</a></li><li id="menu-item-35814" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35814"><a href="https://www.mdislander.com/maine-news">News</a><ul class="sub-menu"><li id="menu-item-35824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35824"><a href="https://www.mdislander.com/maine-news/waterfront">Maritime</a></li><li id="menu-item-49206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49206"><a href="https://www.mdislander.com/maine-news/cops">Cops &#038; Courts</a></li><li id="menu-item-49207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49207"><a href="https://www.mdislander.com/maine-news/education-news">Education</a></li><li id="menu-item-49209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49209"><a href="https://www.mdislander.com/maine-news/political-news">Politics</a></li><li id="menu-item-49208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49208"><a href="https://www.mdislander.com/maine-news/environment">Environment</a></li></ul></li><li id="menu-item-36251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36251"><a href="https://www.mdislander.com/mdi-sports">Sports</a></li><li id="menu-item-35817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35817"><a href="https://www.mdislander.com/living">Lifestyle</a><ul class="sub-menu"><li id="menu-item-49210" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49210"><a href="https://www.mdislander.com/living/arts-a-living">Arts &#038; living</a></li><li id="menu-item-49214" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49214"><a href="https://www.mdislander.com/living/living-entertainment">Entertainment</a></li><li id="menu-item-49211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49211"><a href="https://www.mdislander.com/living/auto-reviews">Auto reviews</a></li><li id="menu-item-49212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49212"><a href="https://www.mdislander.com/living/columnists/ask-carolyn">Ask Carolyn</a></li><li id="menu-item-49213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49213"><a href="https://www.mdislander.com/living/columnists/nature">Nature</a></li><li id="menu-item-49215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49215"><a href="https://www.mdislander.com/horoscope/daily-horoscope">Horoscope</a></li></ul></li><li id="menu-item-35818" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-35818"><a href="https://www.mdislander.com/opinions">Opinion</a><ul class="sub-menu"><li id="menu-item-49218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49218"><a href="https://www.mdislander.com/opinions/editorials">Editorials</a></li><li id="menu-item-49217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49217"><a href="https://www.mdislander.com/opinions/commentary">Commentary</a></li><li id="menu-item-49219" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49219"><a href="https://www.mdislander.com/opinions/letters-to-the-editor">Letters to the editor</a></li><li id="menu-item-49216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49216"><a href="https://www.mdislander.com/opinions/columnists-opinions/jill-goldthwait">State of Maine</a></li></ul></li><li id="menu-item-57079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57079"><a href="https://www.mdislander.com/obituary">Obituaries</a></li><li id="menu-item-35822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35822"><a href="http://www.mainenotices.com/">Public Notices</a></li><li id="menu-item-35823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35823"><a href="https://www.downeastmaine.com/calendar/events/category/events/">Calendar</a></li><li id="menu-item-56315" class="mdi-menu-button menu-item menu-item-type-custom menu-item-object-custom menu-item-56315"><a href="https://www.mdislander.com/subscriptions">SUBSCRIBE</a></li></ul><div class="nav_menu_control"><a href="#" data-prl-offcanvas="{target:'#offcanvas'}"><span class="prl-nav-toggle prl-nav-menu"></span><span class="nav_menu_control_text"></span></a></div><div class="prl-nav-flip show-tablet"><div id="search_form" class="nav_search show-tablet"><form class="prl-search" action="https://www.mdislander.com"> <input type="text" id="s" name="s" value="" placeholder="&#xF002;" class="nav_search_input" /></form></div></div></div></div></nav> <script>var $ = jQuery.noConflict();
			$(document).ready(function() {
				var example = $('#sf-menu').superfish({
					delay:       100,
					animation:   {opacity:'show',height:'show'},
					dropShadows: false,
					autoArrows:  false
				});
			});</script> <!--</div>--><div id="offcanvas" class="prl-offcanvas"><div class="prl-offcanvas-bar"><nav class="side-nav"><ul id="nav-list" class="nav-list"><li id="menu-item-1579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1579"><a href="https://www.mdislander.com/">Home</a></li><li id="menu-item-1987" class="eai-menu-top menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1987"><a href="/maine-news/">News</a><ul class="sub-menu"><li id="menu-item-1620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1620"><a href="https://www.mdislander.com/maine-news/cops">Cops &#038; Courts</a></li><li id="menu-item-2006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2006"><a href="https://www.mdislander.com/maine-news/waterfront">Maritime</a></li><li id="menu-item-1655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1655"><a href="https://www.mdislander.com/maine-news/education-news">Education</a></li><li id="menu-item-1656" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1656"><a href="https://www.mdislander.com/maine-news/business-news">Business</a></li><li id="menu-item-1657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1657"><a href="https://www.mdislander.com/maine-news/health-news">Health</a></li></ul></li><li id="menu-item-2015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2015"><a href="https://www.mdislander.com/mdi-sports">Sports</a></li><li id="menu-item-1599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1599"><a href="https://www.mdislander.com/living">Lifestyle</a></li><li id="menu-item-2018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2018"><a href="https://www.mdislander.com/opinions">Opinion</a></li><li id="menu-item-57082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57082"><a href="https://www.mdislander.com/obituary">Obituaries</a></li><li id="menu-item-1600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1600"><a target="_blank" rel="noopener noreferrer" href="http://www.mainenotices.com/">Public Notices</a></li><li id="menu-item-1610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1610"><a href="https://www.downeastmaine.com/calendar/events/category/events/">Calendar</a></li><li id="menu-item-32512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32512"><a href="https://mountdesertislander-me.newsmemory.com">Digital edition</a></li><li id="menu-item-52386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52386"><a href="http://www.downeastmaine.com/classifieds/helpwanted/">Help Wanted</a></li><li id="menu-item-52387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52387"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li><li id="menu-item-52388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52388"><a href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li><li id="menu-item-52389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52389"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li></ul></nav></div></div><div class="prl-container"><div class="prl-grid prl-grid-divider"><div class="widget-odd widget-last widget-first widget-1 prl-span-12"><div id="text-4" class=" widget_text ad-container"><div class="textwidget"><script data-cfasync="false"  type="text/javascript">broadstreet.zone(43390, {responsive: true});</script></div></div></div><section id="main" class="prl-span-9"> <!-- single --><article id="post-78135" class="article-single post-78135 post type-post status-publish format-standard hentry category-letters-to-the-editor category-opinions"><h1><a href="https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better" rel="bookmark" title="Letter to Editor: We can do better">Letter to Editor: We can do better</a></h1><hr class="prl-grid-divider"><div class ="single-meta"><div class="prl-article-meta"> <span>September 27, 2019</span> on <a href="https://www.mdislander.com/opinions/letters-to-the-editor" rel="category tag">Letters to the editor</a>, <a href="https://www.mdislander.com/opinions" rel="category tag">Opinion</a></div><ul class="prl-list prl-list-sharing"><li><a href="http://www.facebook.com/share.php?u=https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better" target="_blank"><i class="fa fa-facebook-square"></i> </a></li><li><a href="http://twitter.com/home?status=Letter to Editor: We can do better - https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better" target="_blank"><i class="fa fa-twitter-square"></i> </a></li><li><a href="http://pinterest.com/pin/create/button/?url=https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better&media=" class="pin-it-button" count-layout="horizontal" onClick="javascript:window.open(this.href,&#39;&#39;, &#39;menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=320,width=620&#39;);return false;"><i class="fa fa-pinterest-square"></i></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better&title=Letter to Editor: We can do better" target="_blank"><i class="fa fa-linkedin-square"></i></a></li><li><a href="mailto:?subject=Letter to Editor: We can do better&body=https://www.mdislander.com/opinions/letter-to-editor-we-can-do-better" target="_blank"><i class="fa fa-envelope"></i></a></li><li><a href="#" onclick="window.print();" id="print-page" ><i class="fa fa-print"></i></a></li></ul></div><hr class="prl-grid-divider"><div class="prl-grid"><div class="prl-span-12 prl-span-flip"><div class="prl-entry-content clearfix"><p class="IslanderCopy">To the Editor:</p><p class="IslanderCopy">On Monday at the United Nations, Governor Janet Mills pledged that Maine will have a carbon-neutral economy by 2045. And she signed an executive order directing the new Maine Climate Council to deliver recommendations to make this transition in 25 years.</p><p class="IslanderCopy">Sounds good, right? It’s one of the most ambitious pronouncements by any governor in the country.</p><p class="IslanderCopy">But listen to Greta Thunberg, the Swedish teenager who also addressed the UN yesterday:</p><p class="IslanderCopy">&#8220;The popular idea of cutting our emissions in half in 10 years only gives us a 50 percent chance of staying below 1.5 degrees [Celsius], and the risk of setting off irreversible chain reactions beyond human control,&#8221; she said. &#8220;There will not be any solutions or plans presented in line with these figures here today, because these numbers are too uncomfortable.</p><p class="IslanderCopy">&#8220;You are failing us,&#8221; she continued. &#8220;The eyes of all future generations are upon you. Right here, right now is where we draw the line.”</p><p class="IslanderCopy">Today, 40 percent of the energy Maine consumes comes from renewable sources. But we have an abundance of untapped solar, offshore wind and new tidal energy technology that could power 100 percent of our economy. And that doesn’t include the vast amount of wasted energy that can be cost-efficiently conserved.</p><p class="IslanderCopy">Four months ago, Gov. Mills signed into law a bill (LD 658), requiring her administration to develop a plan to make Maine energy independent by 2030. Originated from Mount Desert Island’s grassroots citizen’s organization A Climate to Thrive and sponsored by Rep. Brian Hubbell (Bar Harbor), LD 658 is the most significant action taken this year in Maine responding to the science cited by Thunberg.</p><p class="IslanderCopy">But Governor Mills is a pragmatist. Her political judgment dictates more comfortable goals, 25 years out, by 2045 rather than 2030. So she seems to have already overlooked or ignored the necessity of the urgent action spelled out by LD 658.</p><p class="IslanderCopy">Last week the Islesford Lobstermen’s Coop and MDI High School celebrated the completion of solar arrays that will provide 100 percent of the power for both facilities. These local climate solutions are saving fishermen and taxpayers real money for reinvestment in our communities while paving the way toward a sustainable future.</p><p class="IslanderCopy">We challenge the Governor to do even more.</p><p class="IslanderCopy">Declare that Maine is facing a climate emergency – and act like it. Use the moral and financial authority of the State of Maine to lead in solarizing every State building and making State government net-zero in energy consumption by 2030. Solarize every school and municipal facility by 2030.</p><p class="IslanderCopy">Initiate a crash program in carefully sited offshore wind power.</p><p class="IslanderCopy">Transform Central Maine Power and Emera into Consumer Owned Utilities (COUs) that put the needs of ratepayers and climate ahead of fat profits to foreign shareholders. COUs, mandated to conserve energy and develop smart grids powered by green, local sources, will provide more reliable power at lower costs. COUs will also invest in energy conservation and solar panels for low and moderate-income households, repaid through net savings on utility bills.</p><p class="IslanderCopy">Maine can’t wait until 2045. We can do better, Governor Mills.</p><p class="IslanderCopy">Gary Friedmann</p><p class="IslanderCopy">Bar Harbor</p><div class="prl-span-12 default"><div class="yarpp-thumbnails-horizontal"><div class='yarpp-related'><h4>Related Posts</h4><ul><li><a href="https://www.mdislander.com/opinions/fractious-society" rel="bookmark"> <span class="yarpp-thumbnail"><img width="150" height="150" src="https://www.mdislander.com/wp-content/uploads/sites/5/2017/02/Redding-quote-2.16-e1487102695770-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></span><p class="yarpp-thumbnail-title"> Fractious society</p> </a><!-- (2)--></li><li><a href="https://www.mdislander.com/opinions/trumps-terms" rel="bookmark"> <span class="yarpp-thumbnail"><img width="150" height="150" src="https://www.mdislander.com/wp-content/uploads/sites/5/2017/11/Robins-quote-11.9-e1510090366599-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></span><p class="yarpp-thumbnail-title"> Trump&#8217;s terms</p> </a><!-- (2)--></li><li><a href="https://www.mdislander.com/opinions/letter-to-editor-respect-and-thanks" rel="bookmark"> <span class="yarpp-thumbnail"></span><p class="yarpp-thumbnail-title"> Letter to Editor: Respect and thanks</p> </a><!-- (2)--></li></ul></div></div></div><div class="hide-mobile"><center class="ad-container ad-in-content"><script data-cfasync="false" type="text/javascript">broadstreet.zone(40379, {responsive: true});</script></center></div></div></div></div></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/opinions/letter-to-editor-we-can-do-better#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.mdislander.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='78135' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div><!-- #respond --></section><aside id="sidebar" class="prl-span-3"><div id="advanced_menu-2" class="icon-home widget-odd widget-first widget-1 eai-two-col-menu widget widget_advanced_menu prl-panel clearfix"><h5 class="prl-block-title">News from &#8230;.</h5><div class="menu-towns-container"><ul id="menu-towns" class="menu"><li id="menu-item-1663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663"><a href="https://www.mdislander.com/bar-harbor">Bar Harbor</a></li><li id="menu-item-1660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1660"><a href="https://www.mdislander.com/mount-desert">Mount Desert</a></li><li id="menu-item-1662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1662"><a href="https://www.mdislander.com/southwest-harbor">Southwest Harbor</a></li><li id="menu-item-1661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1661"><a href="https://www.mdislander.com/tremont">Tremont</a></li><li id="menu-item-2082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2082"><a href="https://www.mdislander.com/trenton">Trenton</a></li><li id="menu-item-2083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2083"><a href="https://www.mdislander.com/cranberry-isles">Cranberry Isles</a></li><li id="menu-item-2084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2084"><a href="https://www.mdislander.com/frenchboro">Frenchboro</a></li><li id="menu-item-2085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2085"><a href="https://www.mdislander.com/swans-island">Swan&#8217;s Island</a></li></ul></div></div><div id="text-7" class="widget-even widget-2 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Letters to the Editor Policy</h5><div class="textwidget">The Mount Desert Islander welcomes letters to the editor.
Letters may be edited for libel, slander, taste or length.
Submissions recommending commercial products or establishments will not be accepted. All letters should bear an original signature (e-mail letters must be independently verified) and a telephone number. Letters or submissions for Community Forum should be neatly prepared, and received in the office by Tuesday morning at 10 a.m. To submit a letter or column, email Liz Graves at <a href="mailto:lgraves@mdislander.com">lgraves@mdislander.com</a></div></div><div id="text-8" class="widget-odd widget-last widget-3 widget widget_text prl-panel clearfix"><div class="textwidget"><!-- desktop ad --><div class="eia-right-rail ad-container"><script  data-cfasync="false" id="banner-ad" type="text/javascript">broadstreet.zone(58960, {responsive: true});</script></div> <!-- mobile ad --><div class="eia-right-rail ad-container-mobile"><script data-cfasync="false"  id="banner-ad" type="text/javascript">broadstreet.zone(65229, {responsive: true});</script></div></div></div></aside></div></div><footer id="footer"><div id="over_footer_wrap" ><div id="custom_html-8" class="widget_text widget-odd widget-first widget-1  widget_custom_html eai-overfooter-container"><div class="textwidget custom-html-widget"><h2 class="widgettitle" style="text-align:center;"> Hancock County Yellow Pages</h2><div class="flex-ad-container"><script defer="defer"  type="text/javascript">broadstreet.zone(66948, {responsive: true});</script></div></div></div><div id="text-24" class="widget-even widget-last widget-2  widget_text eai-overfooter-container"><div class="textwidget"><p style="padding-top: 20px; text-align: center;">Advertise your business here. Call Kelley Wescott at (207) 667-2576 or send an <a href="mailto:kwescott@ellsworthamerican.com"> email <i class="fa fa-envelope-o" aria-hidden="true"></i></a>.</p></div></div></div><div class="footer-widget"><div class="prl-container"><div class="prl-grid prl-grid-divider"><div class="prl-span-3"><div id="text-11" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Our Websites</h5><div class="textwidget"><center><a href="//www.ellsworthamerican.com">EllsworthAmerican.com</a></center><center><a href="//www.mdislander.com">MDIslander.com</a></center><center><a href="//www.ellsworthamericaninc.com">About Us</a></center><center><a href="//www.downeastmaine.com/calendar">Calendar</a></center><center><a href="//www.downeastmaine.com/classifieds/helpwanted/" target="_blank" rel="noopener noreferrer">Help Wanted</a></center><center><a href="//www.downeastmaine.com/classifieds/rentals/" target="_blank" rel="noopener noreferrer">Rental Listings</a></center><center><a href="//www.downeastmaine.com/classifieds/realestate/">Real Estate</a></center><center><a href="//ellsworthamerican.smugmug.com/The-Ellsworth-American" target="_blank" rel="noopener noreferrer">View & Purchase Photos</a></center></div></div></div><div class="prl-span-3"><div id="text-12" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Send Us Your&#8230;</h5><div class="textwidget"><center><a href="//www.ellsworthamericaninc.com/submit-a-wedding-engagement-or-anniversary/">Submit a wedding or engagement</a></center><center><a href="//www.ellsworthamericaninc.com/obituaries/">Submit an obituary</a></center><center><a href="//www.ellsworthamericaninc.com/submit-a-photo/">Submit a photo</a></center><center><a href="//www.ellsworthamericaninc.com/submit-news/">Submit news</a></center><center><a href="//www.downeastmaine.com/calendar/events/community/add">Submit a calendar event</a></center><center><a href="//www.ellsworthamericaninc.com./submit-a-cancellation/">Submit cancellation or closing</a></center><center><a href="https://www.ellsworthamericaninc.com/advertise-with-us/classified-ads/" >Submit a classified ad</a></center><center><a href="//www.ellsworthamericaninc.com/contact-us/mount-desert-islander-letter-to-the-editor/">Letters to the Editor</a></center></div></div></div><div class="prl-span-3"><div id="text-13" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Contact</h5><div class="textwidget"><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-advertising/">Advertising</a></center><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-the-ellsworth-american-newsroom/">American News</a></center><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-mount-desert-islander-newsroom/">Islander News</a></center><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-subscriptions/">Circulation</a></center><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-accounting/">Accounting</a></center><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-internet/">Internet Services</a></center><center><a href="//www.mdislander.com/reporters-editors">News Team</a></center><center><a href="//www.reachmaine.com/contact/">Reach Maine Marketing</a></center><center><a href="https://www.mdislander.com/contact-us">Contact Us</a></center></div></div></div><div class="prl-span-3"><div id="nav_menu-2" class="widget-odd widget-last widget-first widget-1 widget widget_nav_menu prl-panel clearfix"><h5 class="prl-block-title">Subscriptions</h5><div class="menu-footer-subscriptions-container"><ul id="menu-footer-subscriptions" class="menu"><li id="menu-item-59889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59889"><a href="//ellsworthamerican-me.newsmemory.com">Access your Ellsworth American digital edition</a></li><li id="menu-item-59890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59890"><a href="//mountdesertislander-me.newsmemory.com/">Access your Mount Desert Islander digital edition</a></li><li id="menu-item-59891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59891"><a href="https://www.mdislander.com/subscriptions/">Subscribe or Renew</a></li><li id="menu-item-59892" class="eai-bright-link menu-item menu-item-type-custom menu-item-object-custom menu-item-59892"><a href="//www.ellsworthamericaninc.com/advertise-with-us/">ADVERTISE</a></li></ul></div></div></div></div></div></div><div class="copyright"><div class="prl-container"><div class="left"> &copy; 2019 by <a href="https://www.mdislander.com">Mount Desert Islander</a> -  All rights reserved. | <a href='http://www.ellsworthamericaninc.com/privacy-policy/'>Privacy Policy</a> | <a href='http://www.ellsworthamericaninc.com/terms-of-use/'>Terms Of Use</a></div><div class="right"><a href="https://www.reachmaine.com">Reach Maine</a></div></div></div><!-- .copyright --></footer><!-- #footer --></div><!-- .site-wrapper --> <a id="toTop" href="#"><i class="fa fa-long-arrow-up"></i></a> <script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;v=0"></script> <link rel='stylesheet' id='yarppRelatedCss-css'  href='https://www.mdislander.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/aqpb-view-js.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/custom.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/imagesloaded.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/masonry.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery.masonry.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/placeholder.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/superfish.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/hoverIntent.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.infinitescroll.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/flexslider.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-content/uploads/sites/5/siteground-optimizer-assets/plugins.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/comment-reply.min.js'></script> <script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/wp-embed.min.js'></script> <script type='text/javascript'>var axel = Math.random() + '';var a = axel * 10000000000000;document.write('<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/6119/DFPAudiencePixel;ord=' + a + ';dc_seg=745020622?" width=1 height=1 border=0/>');</script> <noscript><img src="https://pubads.g.doubleclick.net/activity;dc_iu=/6119/DFPAudiencePixel;ord=1;dc_seg=745020622?" width=1 height=1 border=0/></noscript></body></html>