<!DOCTYPE html>
<html lang="en-US">
<head>
	

    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

		<link rel="shortcut icon" href="https://www.mdislander.com/wp-content/themes/origmag-ea/images/mid_favicon.ico">
			<link href="https://fonts.googleapis.com/css?family=Vollkorn:400,400i,700,700i" rel="stylesheet">
       	<script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;service=onstop&amp;v=0"></script>

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Sparks will fly over MDI this Fourth of July - Mount Desert Islander</title>
	<meta name="description" content="Throughout the holiday weekend, events will be held on Mount Desert Island to celebrate the birth of American independence." />
	<link rel="canonical" href="https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Sparks will fly over MDI this Fourth of July - Mount Desert Islander" />
	<meta property="og:description" content="Throughout the holiday weekend, events will be held on Mount Desert Island to celebrate the birth of American independence." />
	<meta property="og:url" content="https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july" />
	<meta property="og:site_name" content="Mount Desert Islander" />
	<meta property="article:publisher" content="https://www.facebook.com/mdislander/" />
	<meta property="article:published_time" content="2022-07-01T12:39:23+00:00" />
	<meta property="article:modified_time" content="2022-07-01T12:40:22+00:00" />
	<meta property="og:image" content="http://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-1200x630.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="630" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Islander Staff" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Islander Staff" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="7 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.mdislander.com/#organization","name":"Mount Desert Islander","url":"https://www.mdislander.com/","sameAs":["https://www.linkedin.com/company/mount-desert-islander","https://www.youtube.com/channel/UCvRkHCLc-51mSo0CTfemKmw","https://www.facebook.com/mdislander/","https://twitter.com/TheMDIslander"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.mdislander.com/#/schema/logo/image/","url":"https://www.mdislander.com/wp-content/uploads/sites/5/2016/02/fbIslander_teal.jpg","contentUrl":"https://www.mdislander.com/wp-content/uploads/sites/5/2016/02/fbIslander_teal.jpg","width":1200,"height":1200,"caption":"Mount Desert Islander"},"image":{"@id":"https://www.mdislander.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://www.mdislander.com/#website","url":"https://www.mdislander.com/","name":"Mount Desert Islander","description":"Local news &amp; information for MDI and Bar Harbor","publisher":{"@id":"https://www.mdislander.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.mdislander.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#primaryimage","url":"https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443.jpg","contentUrl":"https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443.jpg","width":1200,"height":800,"caption":"One of the lobster representatives from the Mount Desert Island YMCA’s float flashes a smile during the Fourth of July Parade. ISLANDER PHOTO BY SARAH HINCKLEY"},{"@type":"WebPage","@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#webpage","url":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july","name":"Sparks will fly over MDI this Fourth of July - Mount Desert Islander","isPartOf":{"@id":"https://www.mdislander.com/#website"},"primaryImageOfPage":{"@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#primaryimage"},"datePublished":"2022-07-01T12:39:23+00:00","dateModified":"2022-07-01T12:40:22+00:00","description":"Throughout the holiday weekend, events will be held on Mount Desert Island to celebrate the birth of American independence.","breadcrumb":{"@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july"]}]},{"@type":"BreadcrumbList","@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.mdislander.com/"},{"@type":"ListItem","position":2,"name":"Sparks will fly over MDI this Fourth of July"}]},{"@type":"Article","@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#article","isPartOf":{"@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#webpage"},"author":{"name":"Islander Staff","@id":"https://www.mdislander.com/#/schema/person/2b1b4d865b85211a1456caa98f387cd1"},"headline":"Sparks will fly over MDI this Fourth of July","datePublished":"2022-07-01T12:39:23+00:00","dateModified":"2022-07-01T12:40:22+00:00","mainEntityOfPage":{"@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#webpage"},"wordCount":1376,"commentCount":0,"publisher":{"@id":"https://www.mdislander.com/#organization"},"image":{"@id":"https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#primaryimage"},"thumbnailUrl":"https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443.jpg","keywords":["_stickit","Bar Harbor","Mount Desert Island","Southwest Harbor"],"articleSection":["Entertainment","News"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#respond"]}]},{"@type":"Person","@id":"https://www.mdislander.com/#/schema/person/2b1b4d865b85211a1456caa98f387cd1","name":"Islander Staff","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.mdislander.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/0ceba7218090c1dbef37d5e94b965090?s=96&d=blank&r=g","contentUrl":"https://secure.gravatar.com/avatar/0ceba7218090c1dbef37d5e94b965090?s=96&d=blank&r=g","caption":"Islander Staff"},"url":"https://www.mdislander.com/author/RuthRossi08"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Feed" href="https://www.mdislander.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Comments Feed" href="https://www.mdislander.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Sparks will fly over MDI this Fourth of July Comments Feed" href="https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july/feed" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mdislander.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='aqpb-view-css-css'  href='https://www.mdislander.com/wp-content/themes/original/page-builder/assets/css/aqpb-view.css?ver=1656705066' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.mdislander.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='eae_styles-css'  href='https://www.mdislander.com/wp-content/plugins/EAElections2020/eai_results.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://www.mdislander.com/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/css/genericons/genericons.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='ts_fab_css-css'  href='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/css/ts-fab.css?ver=2.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='zsfw-style-css'  href='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/style.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='zsfw-slider-style-css'  href='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/jquery.bxslider.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css'  href='https://www.mdislander.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.15' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css'  href='https://www.mdislander.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.15' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css'  href='https://www.mdislander.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto-Slab-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto-Condensed-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.mdislander.com/wp-content/themes/original/css/font-awesome.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icon-css'  href='https://www.mdislander.com/wp-content/themes/original/css/weather-icons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://www.mdislander.com/wp-content/themes/original/css/flexslider.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-tab-css'  href='https://www.mdislander.com/wp-content/themes/original/css/flexslider-tab.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='superfish-css'  href='https://www.mdislander.com/wp-content/themes/original/css/megafish.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='framework-css'  href='https://www.mdislander.com/wp-content/themes/original/css/framework.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://www.mdislander.com/wp-content/themes/origmag-mdi/style.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='print-css'  href='https://www.mdislander.com/wp-content/themes/original/css/print.css?ver=5.9.3' type='text/css' media='print' />
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery/jquery-1.12.4-wp.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-migrate/jquery-migrate-1.4.1-wp.js?ver=1.4.1-wp' id='jquery-migrate-js'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?v=1.43.8&#038;ver=5.9.3' id='broadstreet-cdn-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/js/ts-fab.js?ver=2.0.8' id='ts_fab_js-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/smugmug-feed.js?ver=5.9.3' id='zsfw-script-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/jquery.bxslider.js?ver=5.9.3' id='zsfw-slider-script-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.9.3' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.9.3' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://www.mdislander.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.mdislander.com/wp-json/wp/v2/posts/96848" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mdislander.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mdislander.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.mdislander.com/?p=96848' />
<link rel="alternate" type="application/json+oembed" href="https://www.mdislander.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mdislander.com%2Fmaine-news%2Fsparks-will-fly-over-mdi-this-fourth-of-july" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mdislander.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mdislander.com%2Fmaine-news%2Fsparks-will-fly-over-mdi-this-fourth-of-july&#038;format=xml" />
  <script type="text/javascript" src="https://www.gstatic.com/charts/loader.js"></script>
  <style>.ts-fab-wrapper .ts-fab-list li a { background-color:#e9e9e9; border: 1px solid #e9e9e9; color: #333; } .ts-fab-wrapper .ts-fab-list li.active a { background-color: #333; border: 1px solid #333; color: #fff; }.ts-fab-wrapper .ts-fab-tab.visible-tab { background-color: #f9f9f9; border: 2px solid #333; color: #555; }</style>
		<!-- GA Google Analytics @ https://m0n.co/ga -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-55634975-4', 'auto');
			ga('send', 'pageview');
		</script>

	<style type="text/css">body{ background-color: #eeeeee}header#masthead .prl-header-logo,button, input[type=submit], input[type=button], a.prl-button,.prl-badge,.page_navi li.current span,.prl-accordion section.active a.head,.prl-nav-dropdown a:hover, .widget_newsletter { background-color:#00829b;}a,.prl-block-title, .prl-block-title a, .prl-archive-title,.prl-archive-title a,#footer .prl-block-title a,.comment-reply-title,#footer .prl-block-title,.twitter_widget a,.sf-menu > li.current-menu-item > a,.sf-menu > li.current_page_item > a,.sf-menu > li.current-menu-ancestor > a,.sf-menu > li.current-menu-parent > a, .sf-menu > li:hover > a,.sf-menu > li.sfHover > a { color:#00829b;}.page_navi li.current span, #sliderTab .slider_content .prl-article-meta{ border-color:#00829b;}h1,h2,h3,h4,h5,h6{font-family: "Roboto Condensed", Arial, Helvetica, sans-serif;}div.eai-scores {
padding-left: 20px;
padding-right: 20px;
}

div.eai-scores ul {
list-style: none;
padding-left: 0px;
padding-bottom: 4px;
font-size: .9em;
}

div.eai-scores li {
padding-left: 11px;
font-weight: bold;
font-size: 1.2em;
}

div.eai-scores p {
padding-bottom: 0px;
margin-bottom: 2px;
color: teal;
}

div.eai-scores h3.prl-article-title {
display: none;
}</style>		<meta name="thumbnail" content="https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-1024x683.jpg"><meta property="og:image" content="https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-1024x683.jpg"></head>
<body class="post-template-default single single-post postid-96848 single-format-standard site-boxed">
	<script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;v=0"></script>
<div id="topbar"><div class="widget-odd widget-last widget-first widget-1 msm-coastal-menu hidden-tablet prl-span-12"><div id="nav_menu-4" class=" widget_nav_menu topbar"><h2 class="widgettitle">COASTAL NEWS:</h2>
<div class="menu-msm-papers-container"><ul id="menu-msm-papers" class="menu"><li id="menu-item-89630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-89630"><a href="https://www.mdislander.com/">MOUNT DESERT ISLANDER</a></li>
<li id="menu-item-89631" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89631"><a href="https://www.ellsworthamerican.com/">ELLSWORTH AMERICAN</a></li>
<li id="menu-item-89632" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89632"><a href="https://knox.villagesoup.com/">CAMDEN HERALD</a></li>
<li id="menu-item-89633" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89633"><a href="https://knox.villagesoup.com/">COURIER-GAZETTE</a></li>
<li id="menu-item-89634" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89634"><a href="https://freepressonline.com/">FREE PRESS</a></li>
<li id="menu-item-89635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-89635"><a href="https://waldo.villagesoup.com/">REPUBLICAN JOURNAL</a></li>
</ul></div></div></div></div>
<div class="site-wrapper">
    <!--<div class="prl-container">-->

		<header id="masthead" class="clearfix">
			<div class="prl-container">
												<div class="prl-nav-flip-top hidden-tablet">
					
					<div id="search_form-top" class="nav_search">
						<form class="prl-search" action="https://www.mdislander.com">
							<input type="text" id="s" name="s" value="" placeholder="&#xF002;" class="nav_search_input" />
													</form>
					</div>

				</div>
												<nav id="topnav" class="hidden-tablet">
					<div class="nav-wrapper clearfix">
					<ul id="top-menu" class="sf-menu eai-menu"><li id="menu-item-1574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1574"><a target="_blank" rel="noopener" href="http://www.downeastmaine.com/classifieds/helpwanted/">Jobs</a></li>
<li id="menu-item-1575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1575"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li>
<li id="menu-item-1576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1576"><a target="_blank" rel="noopener" href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li>
<li id="menu-item-52385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52385"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li>
<li id="menu-item-23064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23064"><a href="http://www.acadiavisitor.com/">Acadia Visitor</a></li>
<li id="menu-item-31935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31935"><a href="https://mountdesertislander-me.newsmemory.com">Digital Edition</a></li>
<li id="menu-item-57478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57478"><a href="https://www.ellsworthamericaninc.com/advertise-with-us/">Advertise</a></li>
</ul>					</div>
				</nav>

			</div> 			<div class="prl-container top-header">
				<div class="masthead-bg clearfix">
				<div class="prl-header-logo"><a href="https://www.mdislander.com" title="Mount Desert Islander"><img src="https://www.mdislander.com/wp-content/uploads/sites/5/2021/11/MDIslander-20-Anniversary-logo_540x85_B.png" alt="Mount Desert Islander" /></a>
				</div>
				<div class="prl-header-mid">
										<span class="prl-header-time"><a href="https://www.downeastmaine.com/calendar/events/today/"><i class="fa fa-calendar"></i>Friday - Jul 01, 2022</a></span>
										<ul class="ea-technav-login ea-leaky-login"><li><a id="ta_account_button" onclick="ta_account()" >~</a></li></ul>				</div>
				<div class="prl-header-social">
					<a href="https://www.facebook.com/mdislander" class="fa fa-facebook" title="Facebook" target="_blank"></a>																				                                        <a href="https://www.youtube.com/user/mountdesertislander" class="youtube-pic" title="Youtube"><img src="https://www.mdislander.com/wp-content/themes/origmag-mdi/images/youtube.jpg"></a>				</div><!-- end of header social -->
			 </div>
			</div>
		</header>
		<nav id="nav" class="prl-navbar" role="navigation">
			<div class="prl-container">
				<div class="nav-wrapper clearfix centered-menu">
				<ul id="sf-menu" class="sf-menu"><li id="menu-item-35813" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-35813"><a href="https://www.mdislander.com">Home</a></li>
<li id="menu-item-35814" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-35814"><a href="https://www.mdislander.com/maine-news">News</a>
<ul class="sub-menu">
	<li id="menu-item-35824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35824"><a href="https://www.mdislander.com/maine-news/waterfront">Maritime</a></li>
	<li id="menu-item-49206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49206"><a href="https://www.mdislander.com/maine-news/cops">Cops &amp; Courts</a></li>
	<li id="menu-item-49207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49207"><a href="https://www.mdislander.com/maine-news/education-news">Education</a></li>
	<li id="menu-item-49209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49209"><a href="https://www.mdislander.com/maine-news/political-news">Politics</a></li>
	<li id="menu-item-49208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49208"><a href="https://www.mdislander.com/maine-news/environment">Environment</a></li>
	<li id="menu-item-91216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91216"><a href="https://www.mdislander.com/podcast">Podcast</a></li>
</ul>
</li>
<li id="menu-item-36251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36251"><a href="https://www.mdislander.com/mdi-sports">Sports</a></li>
<li id="menu-item-35817" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-35817"><a href="https://www.mdislander.com/living">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-49210" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49210"><a href="https://www.mdislander.com/living/arts-a-living">Arts &amp; living</a></li>
	<li id="menu-item-49214" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49214"><a href="https://www.mdislander.com/living/living-entertainment">Entertainment</a></li>
	<li id="menu-item-49211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49211"><a href="https://www.mdislander.com/living/auto-reviews">Auto reviews</a></li>
	<li id="menu-item-49213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49213"><a href="https://www.mdislander.com/living/columnists/nature">Nature</a></li>
</ul>
</li>
<li id="menu-item-35818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35818"><a href="https://www.mdislander.com/opinions">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-49218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49218"><a href="https://www.mdislander.com/opinions/editorials">Editorials</a></li>
	<li id="menu-item-49217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49217"><a href="https://www.mdislander.com/opinions/commentary">Commentary</a></li>
	<li id="menu-item-49219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49219"><a href="https://www.mdislander.com/opinions/letters-to-the-editor">Letters to the editor</a></li>
	<li id="menu-item-49216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49216"><a href="https://www.mdislander.com/opinions/columnists-opinions/jill-goldthwait">State of Maine</a></li>
</ul>
</li>
<li id="menu-item-57079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57079"><a href="https://www.mdislander.com/obituary">Obituaries</a></li>
<li id="menu-item-35822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35822"><a href="http://www.mainenotices.com/">Public Notices</a></li>
<li id="menu-item-35823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35823"><a href="https://www.downeastmaine.com/calendar/events/category/events/">Calendar</a></li>
<li id="menu-item-56315" class="mdi-menu-button menu-item menu-item-type-custom menu-item-object-custom menu-item-56315"><a href="https://www.mdislander.com/subscriptions">SUBSCRIBE</a></li>
</ul>
				<div class="nav_menu_control"><a href="#" data-prl-offcanvas="{target:'#offcanvas'}"><span class="prl-nav-toggle prl-nav-menu"></span><span class="nav_menu_control_text"></span></a>
				</div>
								<div class="prl-nav-flip show-tablet">
					
					<div id="search_form" class="nav_search show-tablet">
						<form class="prl-search" action="https://www.mdislander.com">
							<input type="text" id="s" name="s" value="" placeholder="&#xF002;" class="nav_search_input" />
													</form>
					</div>

				</div>
				
				</div>
			</div>
		</nav>

		<script>
			var $ = jQuery.noConflict();
			$(document).ready(function() {
				var example = $('#sf-menu').superfish({
					delay:       100,
					animation:   {opacity:'show',height:'show'},
					dropShadows: false,
					autoArrows:  false
				});
			});

		</script>

    <!--</div>-->
	<div id="offcanvas" class="prl-offcanvas">
	<div class="prl-offcanvas-bar">
		<nav class="side-nav">
		<ul id="nav-list" class="nav-list"><li id="menu-item-1579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1579"><a href="https://www.mdislander.com/">Home</a></li>
<li id="menu-item-82248" class="mdi-menu-button menu-item menu-item-type-custom menu-item-object-custom menu-item-82248"><a href="https://www.mdislander.com/subscriptions">Subscribe</a></li>
<li id="menu-item-1987" class="eai-menu-top menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1987"><a href="/maine-news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-1620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1620"><a href="https://www.mdislander.com/maine-news/cops">Cops &amp; Courts</a></li>
	<li id="menu-item-2006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2006"><a href="https://www.mdislander.com/maine-news/waterfront">Maritime</a></li>
	<li id="menu-item-1655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1655"><a href="https://www.mdislander.com/maine-news/education-news">Education</a></li>
	<li id="menu-item-1656" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1656"><a href="https://www.mdislander.com/maine-news/business-news">Business</a></li>
	<li id="menu-item-1657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1657"><a href="https://www.mdislander.com/maine-news/health-news">Health</a></li>
</ul>
</li>
<li id="menu-item-2015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2015"><a href="https://www.mdislander.com/mdi-sports">Sports</a></li>
<li id="menu-item-1599" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-1599"><a href="https://www.mdislander.com/living">Lifestyle</a></li>
<li id="menu-item-2018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2018"><a href="https://www.mdislander.com/opinions">Opinion</a></li>
<li id="menu-item-57082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57082"><a href="https://www.mdislander.com/obituary">Obituaries</a></li>
<li id="menu-item-91217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91217"><a href="https://www.mdislander.com/podcast">Podcast</a></li>
<li id="menu-item-1600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1600"><a target="_blank" rel="noopener" href="http://www.mainenotices.com/">Public Notices</a></li>
<li id="menu-item-1610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1610"><a href="https://www.downeastmaine.com/calendar/events/category/events/">Calendar</a></li>
<li id="menu-item-32512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32512"><a href="https://mountdesertislander-me.newsmemory.com">Digital edition</a></li>
<li id="menu-item-52386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52386"><a href="http://www.downeastmaine.com/classifieds/helpwanted/">Help Wanted</a></li>
<li id="menu-item-52387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52387"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li>
<li id="menu-item-52388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52388"><a href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li>
<li id="menu-item-52389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52389"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li>
</ul>		</nav>
</div></div><div class="prl-container">
    <div class="prl-grid prl-grid-divider">
    	<div id="single-top-ad" class=prl-span-12><div class="widget-odd widget-last widget-first widget-1 eai-ad-container eai-ad-across prl-span-12"><div id="bs_zones-10" class=" bs_zones ad-container"><div><broadstreet-zone zone-id="43389" keywords="not_home_page,not_landing_page,is_article_page,living-entertainment,living,maine-news,sparks-will-fly-over-mdi-this-fourth-of-july,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div></div></div>        <section id="main" class="prl-span-9"> <!-- single -->
        			   		   <article id="post-96848" class="article-single post-96848 post type-post status-publish format-standard has-post-thumbnail hentry category-living-entertainment category-maine-news tag-_stickit tag-bar-harbor tag-mount-desert-island tag-southwest-harbor">
		   		<meta itemprop="image" content="https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443.jpg"></meta>											<div class="single-post-thumbnail ">
							<img width="1200" height="800" src="https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-1200x800.jpg" class="attachment-ea_featuredimg size-ea_featuredimg wp-post-image" alt="" srcset="https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443.jpg 1200w, https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-300x200.jpg 300w, https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-1024x683.jpg 1024w, https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-768x512.jpg 768w, https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-600x400.jpg 600w, https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443-400x267.jpg 400w" sizes="(max-width: 1200px) 100vw, 1200px" />						</div>
						<div class="single-post-thumbnail-caption space-bot">
              <div class="ccfic"><span class="ccfic-text">One of the lobster representatives from the Mount Desert Island YMCA’s float flashes a smile during the 2021 Fourth of July Parade. </span> <span class="ccfic-source">ISLANDER FILE PHOTO</span></div>						</div>
								   <h1><a href="https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july" rel="bookmark" title="Sparks will fly over MDI this Fourth of July">Sparks will fly over MDI this Fourth of July</a></h1>
			   <hr class="prl-grid-divider">
				<div class ="single-meta">
			   			<div class="prl-article-meta">
		<span>July 1, 2022</span>						on <a href="https://www.mdislander.com/living/living-entertainment" rel="category tag">Entertainment</a>, <a href="https://www.mdislander.com/maine-news" rel="category tag">News</a> 
	</div>

<ul class="prl-list prl-list-sharing">
	<li><a href="http://www.facebook.com/share.php?u=https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july" target="_blank"><i class="fa fa-facebook-square"></i> </a></li>
	<li><a href="http://twitter.com/home?status=Sparks will fly over MDI this Fourth of July - https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july" target="_blank"><i class="fa fa-twitter-square"></i> </a></li>
		<li><a href="http://pinterest.com/pin/create/button/?url=https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july&media=https://www.mdislander.com/wp-content/uploads/sites/5/2021/07/PAGE-1-KLO-July-4-0443.jpg" class="pin-it-button" count-layout="horizontal" onClick="javascript:window.open(this.href,&#39;&#39;, &#39;menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=320,width=620&#39;);return false;"><i class="fa fa-pinterest-square"></i></a></li>
	<li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.mdislander.com/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july&title=Sparks will fly over MDI this Fourth of July" target="_blank"><i class="fa fa-linkedin-square"></i></a></li>
	<li><a href="/cdn-cgi/l/email-protection#78470b0d1a121d1b0c452b08190a130b580f111414581e140158170e1d0a58353c31bad80c10110b583e170d0a0c1058171e58320d14015e1a171c0145100c0c080b4257570f0f0f56151c110b1419161c1d0a561b171557151911161d55161d0f0b570b08190a130b550f111414551e140155170e1d0a55151c11550c10110b551e170d0a0c1055171e55120d1401" target="_blank"><i class="fa fa-envelope"></i></a></li>
	<li><a href="#" onclick="window.print();" id="print-page" ><i class="fa fa-print"></i></a></li>
</ul>

				</div>
			   <hr class="prl-grid-divider">
			   <div class="prl-grid">
					<div class="prl-span-12 prl-span-flip">
						<div class="prl-entry-content clearfix">

						                  
               <p><i><span data-contrast="auto">Island-wide Fourth of July fireworks and activities</span></i><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">MOUNT DESERT ISLAND — </span></b><span data-contrast="auto">Independence Day falls on Monday this year, giving people a true four-day weekend. Throughout the holiday weekend, events will be held to celebrate the birth of American independence. On July 4, 1776, the Second Continental Congress unanimously adopted the Declaration of Independence, announcing a separation from Great Britain’s constitutional monarchy. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">According to the Bar Harbor Chamber of Commerce website, Bar Harbor’s Fourth of July has been voted the number one Fourth of July celebration in America by the Today Show and recognized by National Geographic as one of the top 10 in the U.S. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p>&nbsp;</p>
<div class="eai-ad-container eai-ad-incontent"><broadstreet-zone zone-id="77225" keywords="not_home_page,not_landing_page,is_article_page,living-entertainment,living,maine-news,sparks-will-fly-over-mdi-this-fourth-of-july,post" soft-keywords="true" zone-alias=""></broadstreet-zone>
<broadstreet-zone zone-id="77226" keywords="not_home_page,not_landing_page,is_article_page,living-entertainment,living,maine-news,sparks-will-fly-over-mdi-this-fourth-of-july,post" soft-keywords="true" zone-alias="zzz"></broadstreet-zone></div><p><strong>July Fourth parking </strong></p>
<p><span data-contrast="auto">No parking will be allowed after noon July 4 in the Newport Drive parking lot and on-street portions of Main and West adjacent to Agamont Park. Parking from Bridge Street to Bar Island is discouraged. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Police will not enforce paid parking at meters and kiosks, but illegally parked vehicles will be ticketed and/or towed. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">The parade begins at 10 a.m. and fireworks at 9:15 p.m. Close to 9 p.m., Eden Street from Mount Desert Street to Cottage Street will be closed to vehicle traffic. Residents of Michigan, Bowles, Myrtle and Brewer avenues will be unable to use Eden Street for a short period of time to accommodate Island Explorer bus parking. Eden Street will be reopened to traffic as soon as possible. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Second Annual MDI YMCA Lobster Scavenger Hunt</span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">The second Annual Mount Desert Island YMCA Lobster Scavenger Hunt will take place July 1-5 in downtown Bar Harbor. Those who choose to participate will search for lobsters at downtown businesses. Scavenger hunt cards will be available at the MDI YMCA at 21 Park St. in Bar Harbor beginning July 1 at 6 a.m. The MDI YMCA’s deadline for participant’s completed cards is noon on July 5. The submitted cards will be entered into a raffle for a chance to win prizes. Official YMCA Lobster Scavenger Hunt gear can also be purchased, including T-shirts, lobster hats and tote bags, sponsored by Geddy’s, when they visit the MDI YMCA from June 27 to July 5.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Bar Harbor (MDI) Rotary Club Pancake Breakfast</span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">On July 4 from 6-10 a.m., a traditional pancake breakfast will be hosted by the Bar Harbor (MDI) Rotary Club. The morning feast at the Bar Harbor Athletic Field on Park Street will offer blueberry or plain pancakes, breakfast sandwiches, sausage, orange juice, milk, water, tea and coffee. The funds raised from the event will support Rotary projects and local nonprofits.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Island Arts Association Craft Fair/Marketplace</span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">A craft fair/marketplace will be hosted by Island Arts Association at the MDI YMCA at 21 Park St. on July 4 from 9 a.m. to 3 p.m. The fair will have an array of crafts, handmade by Maine artisans, including jewelry, quilts, photographs, pottery and porcelain dolls. Proceeds from the fair will benefit the MDI YMCA and YWCA Mount Desert Island. For more information, call YWCA MDI at (207) 288-5008.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Independence Day Parade </span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">The Bar Harbor Chamber of Commerce will host its traditional Independence Day Parade, which will feature local businesses, organizations and community members, at 10 a.m. on July 4. The parade, led by Grand Marshal Matt Horton, will make its way through downtown Bar Harbor starting on Main Street, down Cottage Street, Eden Street and Mount Desert Street and ending on Ledgelawn Avenue. View the parade route online at https://tinyurl.com/35k4nrw7.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">The Bar Harbor (MDI) Rotary Club Seafood Festival </span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Lunch will be offered at the Bar Harbor Athletic Field on Park Street during the Bar Harbor (MDI) Rotary Club’s Seafood Festival from 11 a.m. to 2 p.m. on July 4. Food options will include Maine lobster and crab rolls, hot dogs, hamburgers, French fries, snacks and beverages. All funds raised from the event support local Rotary projects and local nonprofits.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Live Music at the Town Pier</span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Leading up to the fireworks celebration on July 4, the Bar Harbor Chamber of Commerce’s Free Concert Series is set to take place at the Town Pier from 3-9 p.m. The event, which gives folks a chance to find a seat for the fireworks, will feature family-friendly music with performances by The Smith Collaboration, River Bottom Funk and The Crown Vics. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Town band at the Village Green</span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">The Bar Harbor Town Band will perform at the Village Green at 7:30 p.m.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">Bar Harbor/Acadia National Park July 4th Fireworks </span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">At approximately 9:15 p.m., the Fireworks Over Frenchman Bay event will take place on the waterfront in downtown Bar Harbor. The fireworks display is being sponsored by the Bar Harbor Regency, Bar Harbor Whale Watch Company, Harborside Hotel, Spa &amp; Marina, Stewman&#8217;s Lobster Pound and the Town of Bar Harbor.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><b><span data-contrast="auto">2022 Quietside Fireworks</span></b><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">The Southwest Harbor &amp; Tremont Chamber of Commerce, with the help of numerous Quietside resident and visitors, will be hosting a fireworks display in Southwest Harbor at 9 p.m. on July 4. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Central Maine Pyrotechnics will produce the program, which will be launched from one of Acadia Fuel&#8217;s barges in the middle of the harbor. The fireworks will be visible from many locations around the harbor and local businesses will be hosting viewings from their waterfront locations.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">This display is made possible by donations from Quietside businesses, residents and visitors. The donation of the use of the barge by Acadia Fuel is also instrumental, according to the Chamber of Commerce.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">A rain date of July 9 has been scheduled. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">The Chamber is already accepting contributions for next year’s program and future displays.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">For more information, call (207) 244-9264 or email </span><a href="/cdn-cgi/l/email-protection#fb949d9d92989ebb9a989a9f929a98939a96999e89d5989496"><span data-contrast="none"><span class="__cf_email__" data-cfemail="274841414e444267464446434e46444f464a4542550944484a">[email&#160;protected]</span></span></a><span data-contrast="auto">. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">A fireworks map can be viewed online at <a href="https://acadiachamber.com/files/fireworks_map.pdf">https://acadiachamber.com/files/fireworks_map.pdf</a>.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><strong>ANP shares visitor tips for busy Independence Day weekend  </strong></p>
<p><b><span data-contrast="auto">ACADIA NAT’L PARK</span></b><span data-contrast="auto"> — The National Park Service is expecting high visitation at Acadia National Park over Independence Day weekend. Visitors should plan their trip and expect long lines and wait times, traffic congestion and limited parking at the park’s most popular destinations.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Visitors should arrive with a plan and a backup plan in case parking is unavailable. Go to www.</span><a href="https://www.nps.gov/acad/index.htm"><span data-contrast="none">nps.gov/Acadia</span></a><span data-contrast="auto"> to learn about places to go and things to do in the park before arrival. Download the </span><a href="https://www.nps.gov/subjects/digital/nps-apps.htm"><span data-contrast="none">NPS App</span></a><span data-contrast="auto"> to help guide a visit to Acadia and select “save this park for offline use.” Park only in designated parking spaces. Parking illegally is unsafe and adds to the traffic congestion. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Leave cars parked at place of lodging and ride the fare-free Island Explorer bus, which connects the park with the surrounding communities on Mount Desert Island and the Schoodic Peninsula. Download the </span><a href="https://islandexplorertracker.availtec.com/InfoPoint/"><span data-contrast="none">myStop</span></a><span data-contrast="auto"> app to view real-time bus locations and next available buses. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Visitors 16 and older are required to have a </span><a href="https://www.nps.gov/acad/planyourvisit/fees.htm"><span data-contrast="none">park entrance pass</span></a><span data-contrast="auto">, which can be purchased online at www.</span><a href="https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.recreation.gov%2Fsitepass%2F74271&amp;data=05%7C01%7Csean_bonnage%40nps.gov%7C52c526dcfdd44f4e298d08da532bb724%7C0693b5ba4b184d7b9341f32f400a5494%7C0%7C0%7C637913744581619268%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=T%2F1067LjP75WGH%2BvzJye8G8G3VbHYz%2BKiO6O1JwWn3g%3D&amp;reserved=0"><span data-contrast="none">Recreation.gov</span></a><span data-contrast="auto"> or in person at the Hulls Cove Visitor Center. Vehicles must display a park entrance pass through the windshield. Entrance fees help enhance the visitor experience and protect resources at Acadia National Park.  </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Vehicle reservations are required for Cadillac Summit Road through Oct. 22 and must be purchased online at www.</span><a href="https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.recreation.gov%2Ftimed-entry%2F400000&amp;data=05%7C01%7Csean_bonnage%40nps.gov%7C52c526dcfdd44f4e298d08da532bb724%7C0693b5ba4b184d7b9341f32f400a5494%7C0%7C0%7C637913744581619268%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=yQvTpUKFQGQUFxmis7LQ12ISTWYcQxZjHVd4lED1UxA%3D&amp;reserved=0"><span data-contrast="none">Recreation.gov</span></a><span data-contrast="auto"> before arriving. Print or download the ticket with the QR code for validation. Reservations are not available for purchase in person. Vehicle reservations are not required for other locations in the park or for visitors who enter the area by foot, bicycle or taxi.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Camping reservations are required for park campgrounds and can be purchased on www.</span><a href="https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.recreation.gov%2Fcamping%2Fgateways%2F2554&amp;data=05%7C01%7Csean_bonnage%40nps.gov%7C52c526dcfdd44f4e298d08da532bb724%7C0693b5ba4b184d7b9341f32f400a5494%7C0%7C0%7C637913744581775465%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;sdata=G4n8cQiR1cY6QM4%2BAzBIp8yVcrAcY1Turv3Ge7ozh8s%3D&amp;reserved=0"><span data-contrast="none">Recreation.gov</span></a><span data-contrast="auto">. Same day or walk-up reservations are not available. Backcountry camping, campfires and overnight parking are prohibited outside of designated campgrounds. Fireworks are prohibited in the park. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><a href="https://www.nps.gov/acad/planyourvisit/hiking.htm"><span data-contrast="none">Hikers</span></a><span data-contrast="auto"> should know the difficulty of the park’s trails and select those that match their abilities (many of Acadia’s hikes are more challenging than they seem). Carry a detailed trail map with topography and don&#8217;t rely on cell connectivity for trail navigation. Seventy percent of injuries to hikers in Acadia are due to slips, trips and falls. Wear sturdy footwear and beware of loose gravel, slippery rock, steep climbs and uneven surfaces.  </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">Depending on CDC guidelines and the COVID-19 community level in Hancock County, masks may be required to enter park buildings, including the Hulls Cove Visitor Center, regardless of vaccination status. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>

						   						   
						   						</div>
					</div>

			   </div>

		   </article>

		   
		   		   

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/maine-news/sparks-will-fly-over-mdi-this-fourth-of-july#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.mdislander.com/wp-comments-post.php?wpe-comment-post=ellsammdi" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='96848' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
						        </section>

        <aside id="sidebar" class="prl-span-3">

            <div id="text-32" class="widget-odd widget-first widget-1 eai-wborder-teal widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Trouble logging into your digital subscription?</h5>			<div class="textwidget"><p style="padding-left: 5px;">Request your password <a style="color: #00839c; font-weight: bold;" href="https://southportlandme.circulationpro.com/scripts/WebObjects.exe/SouthPortlandMOUNTDESERTISLANDERSubSS.woa">here</a>.<br />
Or contact our help desk at <a href="tel:2076672576"><strong>(207) 667-2576</strong> </a>during normal business hours or send us an <a style="color: #00839c; font-weight: bold;" href="https://www.ellsworthamericaninc.com/contact-us/contact-subscriptions/">email.</a></p>
<p style="text-align: center; margin-bottom: 10px;"><a style="background-color: #00839c; color: white; padding: 6px 10px;" href="https://southportlandme.circulationpro.com/scripts/WebObjects.exe/SouthPortlandMOUNTDESERTISLANDERSubSS.woa">Request Password</a></p>
</div>
		</div><div id="advanced_menu-2" class="icon-home widget-even widget-2 eai-two-col-menu widget widget_advanced_menu prl-panel clearfix"><h5 class="prl-block-title">News from &#8230;.</h5><div class="menu-towns-container"><ul id="menu-towns" class="menu"><li id="menu-item-1663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663"><a href="https://www.mdislander.com/bar-harbor">Bar Harbor</a></li>
<li id="menu-item-1660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1660"><a href="https://www.mdislander.com/mount-desert">Mount Desert</a></li>
<li id="menu-item-1662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1662"><a href="https://www.mdislander.com/southwest-harbor">Southwest Harbor</a></li>
<li id="menu-item-1661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1661"><a href="https://www.mdislander.com/tremont">Tremont</a></li>
<li id="menu-item-2082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2082"><a href="https://www.mdislander.com/trenton">Trenton</a></li>
<li id="menu-item-2083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2083"><a href="https://www.mdislander.com/cranberry-isles">Cranberry Isles</a></li>
<li id="menu-item-2084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2084"><a href="https://www.mdislander.com/frenchboro">Frenchboro</a></li>
<li id="menu-item-2085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2085"><a href="https://www.mdislander.com/swans-island">Swan&#8217;s Island</a></li>
</ul></div></div><div id="bs_zones-5" class="widget-odd widget-3 eia-right-rail eai-ad-container eai-ad-right eai-ad-300w widget bs_zones prl-panel clearfix"><div><broadstreet-zone zone-id="76192" keywords="not_home_page,not_landing_page,is_article_page,living-entertainment,living,maine-news,sparks-will-fly-over-mdi-this-fourth-of-july,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-27" class="widget-even widget-last widget-4 eia-right-rail eai-ad-container eai-ad-right eai-ad-300w widget bs_zones prl-panel clearfix"><div><broadstreet-zone zone-id="82905" keywords="not_home_page,not_landing_page,is_article_page,living-entertainment,living,maine-news,sparks-will-fly-over-mdi-this-fourth-of-july,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div>	
	

        </aside>
    </div>
</div>


	<footer id="footer">
		<div id="over_footer_wrap" ><div id="bs_zones-2" class="widget-odd widget-first widget-1  bs_zones eai-overfooter-container"><div><broadstreet-zone zone-id="66948" keywords="not_home_page,not_landing_page,is_article_page,living-entertainment,living,maine-news,sparks-will-fly-over-mdi-this-fourth-of-july,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="text-24" class="widget-even widget-last widget-2  widget_text eai-overfooter-container">			<div class="textwidget"><p style="padding-top: 20px; text-align: center;">Advertise your business here. Call Kelley Wescott at (207) 667-2576 or send an <a href="/cdn-cgi/l/email-protection#7a110d1f0919150e0e3a1f1616090d15080e121b171f0813191b1454191517"> email <i class="fa fa-envelope-o" aria-hidden="true"></i></a>.</p>
</div>
		</div></div>				<div class="footer-widget">
			<div class="prl-container">
				<div class="prl-grid prl-grid-divider">
										<div class="prl-span-3">
						<div id="text-11" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Our Websites</h5>			<div class="textwidget"><center><a href="//www.ellsworthamerican.com">EllsworthAmerican.com</a></center>
<center><a href="//www.mdislander.com">MDIslander.com</a></center><center><a href="//www.ellsworthamericaninc.com">About Us</a></center>
<center><a href="//www.mainestaymedia.com/careers" target="_blank" rel="noopener">Work with Us</a></center>
<center><a href="//www.downeastmaine.com/calendar">Calendar</a></center>
<center><a href="//www.downeastmaine.com/classifieds/helpwanted/" target="_blank" rel="noopener">Help Wanted</a></center>
<center><a href="//www.downeastmaine.com/classifieds/rentals/" target="_blank" rel="noopener">Rental Listings</a></center>
<center><a href="//www.downeastmaine.com/classifieds/realestate/">Real Estate</a></center>
<center><a href="//ellsworthamerican.smugmug.com/The-Ellsworth-American" target="_blank" rel="noopener">View & Purchase Photos</a></center></div>
		</div>					</div>
										<div class="prl-span-3">
						<div id="text-12" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Send Us Your&#8230;</h5>			<div class="textwidget"><center><a href="//www.ellsworthamericaninc.com/submit-a-wedding-engagement-or-anniversary/">Submit a wedding or engagement</a></center>
<center><a href="//www.ellsworthamericaninc.com/obituaries/">Submit an obituary</a></center>
<center><a href="https://www.ellsworthamericaninc.com/submit-a-photo-to-the-mdislander/">Submit a photo</a></center>
<center><a href="//www.ellsworthamericaninc.com/submit-news/">Submit news</a></center>
<center><a href="//www.downeastmaine.com/calendar/events/community/add">Submit a calendar event</a></center>
<center><a href="//www.ellsworthamericaninc.com./submit-a-cancellation/">Submit cancellation or closing</a></center>
<center><a href="https://www.ellsworthamericaninc.com/advertise-with-us/classified-ads/" >Submit a classified ad</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/mount-desert-islander-letter-to-the-editor/">Letters to the Editor</a></center></div>
		</div>					</div>
										<div class="prl-span-3">
						<div id="text-13" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Contact</h5>			<div class="textwidget"><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-advertising/">Advertising</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-the-ellsworth-american-newsroom/">American News</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-mount-desert-islander-newsroom/">Islander News</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-subscriptions/">Circulation</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-accounting/">Accounting</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-internet/">Internet Services</a></center>
<center><a href="//www.mdislander.com/reporters-editors">News Team</a></center>
<center><a href="//www.reachmaine.com/contact/">Reach Maine Marketing</a></center>
<center><a href="http://www.mdislander.com/contact-us">Contact Us</a></center></div>
		</div>					</div>
										<div class="prl-span-3">
						<div id="nav_menu-2" class="widget-odd widget-last widget-first widget-1 widget widget_nav_menu prl-panel clearfix"><h5 class="prl-block-title">Subscriptions</h5><div class="menu-footer-subscriptions-container"><ul id="menu-footer-subscriptions" class="menu"><li id="menu-item-59889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59889"><a href="//ellsworthamerican-me.newsmemory.com">Access your Ellsworth American digital edition</a></li>
<li id="menu-item-59890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59890"><a href="//mountdesertislander-me.newsmemory.com/">Access your Mount Desert Islander digital edition</a></li>
<li id="menu-item-59891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59891"><a href="http://www.mdislander.com/subscriptions/">Subscribe or Renew</a></li>
<li id="menu-item-59892" class="eai-bright-link menu-item menu-item-type-custom menu-item-object-custom menu-item-59892"><a href="//www.ellsworthamericaninc.com/advertise-with-us/">ADVERTISE</a></li>
</ul></div></div>					</div>
									</div>
			</div>
		</div>
				<div class="copyright">
			<div class="prl-container">
				<div class="left">
					&copy; 2022 by <a href="https://www.mdislander.com">Mount Desert Islander</a> -  All rights reserved. | <a href='http://www.ellsworthamericaninc.com/privacy-policy/'>Privacy Policy</a> | <a href='http://www.ellsworthamericaninc.com/terms-of-use/'>Terms Of Use</a>
				</div>
				<div class="right"><a href="https://www.reachmaine.com">Reach Maine</a></div>
			</div>
		</div><!-- .copyright -->

	</footer><!-- #footer -->

</div><!-- .site-wrapper -->
		<a id="toTop" href="#"><i class="fa fa-long-arrow-up"></i></a>
			<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;v=0"></script>
			<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','living-entertainment','living','maine-news','sparks-will-fly-over-mdi-this-fourth-of-july','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["living-entertainment","living","maine-news","sparks-will-fly-over-mdi-this-fourth-of-july","post"],"url":"sparks-will-fly-over-mdi-this-fourth-of-july"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script><script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/page-builder/assets/js/aqpb-view.js?ver=1656705066' id='aqpb-view-js-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/www.mdislander.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"d0cfaea4b1","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.15' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/custom.js?ver=5.9.3' id='custom-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b' id='jquery-masonry-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.placeholder.js?ver=5.9.3' id='placeholder-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/superfish.js?ver=5.9.3' id='superfish-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/hoverIntent.min.js?ver=1.10.2' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.infinitescroll.min.js?ver=5.9.3' id='infinitescroll-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.flexslider-min.js?ver=5.9.3' id='flexslider-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/plugins.js?ver=5.9.3' id='plugins-js'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
	<!--<script type='text/javascript'>var axel = Math.random() + '';var a = axel * 10000000000000;document.write('<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/6119/DFPAudiencePixel;ord=' + a + ';dc_seg=745020622?" width=1 height=1 border=0/>');</script>
<noscript><img src="https://pubads.g.doubleclick.net/activity;dc_iu=/6119/DFPAudiencePixel;ord=1;dc_seg=745020622?" width=1 height=1 style="display:none;" border=0/></noscript> -->		</body>
</html>
