<!DOCTYPE html>
<html lang="en-US">
<head>
	

    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

		<link rel="shortcut icon" href="https://www.mdislander.com/wp-content/themes/origmag-ea/images/mid_favicon.ico">
			<link href="https://fonts.googleapis.com/css?family=Vollkorn:400,400i,700,700i" rel="stylesheet">
    	   	<script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;service=onstop&amp;v=0"></script>
		 
	<!-- This site is optimized with the Yoast SEO plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Island (and beyond) Briefs - Mount Desert Islander</title>
	<meta name="description" content="Death Café Oct. 20  BAR HARBOR— MDI Hospital&#039;s palliative care advisory committee will hold a Death Café on Oct. 20 from 6-7:30 p.m. over Zoom.  Death" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.mdislander.com/maine-news/island-and-beyond-briefs" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Island (and beyond) Briefs - Mount Desert Islander" />
	<meta property="og:description" content="Death Café Oct. 20  BAR HARBOR— MDI Hospital&#039;s palliative care advisory committee will hold a Death Café on Oct. 20 from 6-7:30 p.m. over Zoom.  Death" />
	<meta property="og:url" content="https://www.mdislander.com/maine-news/island-and-beyond-briefs" />
	<meta property="og:site_name" content="Mount Desert Islander" />
	<meta property="article:publisher" content="https://www.facebook.com/mdislander/" />
	<meta property="article:published_time" content="2020-10-16T13:24:23+00:00" />
	<meta property="article:modified_time" content="2020-10-16T13:59:48+00:00" />
	<meta property="og:image" content="https://www.mdislander.com/wp-content/uploads/sites/5/2020/10/Island-map-WEB-1200x630.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="630" />
	<meta property="fb:app_id" content="3033880126696311" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.mdislander.com/#organization","name":"Mount Desert Islander","url":"https://www.mdislander.com/","sameAs":["https://www.facebook.com/mdislander/","https://www.linkedin.com/company/mount-desert-islander","https://www.youtube.com/channel/UCvRkHCLc-51mSo0CTfemKmw","https://twitter.com/TheMDIslander"],"logo":{"@type":"ImageObject","@id":"https://www.mdislander.com/#logo","inLanguage":"en-US","url":"https://www.mdislander.com/wp-content/uploads/sites/5/2016/02/fbIslander_teal.jpg","width":1200,"height":1200,"caption":"Mount Desert Islander"},"image":{"@id":"https://www.mdislander.com/#logo"}},{"@type":"WebSite","@id":"https://www.mdislander.com/#website","url":"https://www.mdislander.com/","name":"Mount Desert Islander","description":"Local news &amp; information for MDI and Bar Harbor","publisher":{"@id":"https://www.mdislander.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.mdislander.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#primaryimage","inLanguage":"en-US","url":"https://www.mdislander.com/wp-content/uploads/sites/5/2020/10/Island-map-WEB.jpg","width":1200,"height":800},{"@type":"WebPage","@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#webpage","url":"https://www.mdislander.com/maine-news/island-and-beyond-briefs","name":"Island (and beyond) Briefs - Mount Desert Islander","isPartOf":{"@id":"https://www.mdislander.com/#website"},"primaryImageOfPage":{"@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#primaryimage"},"datePublished":"2020-10-16T13:24:23+00:00","dateModified":"2020-10-16T13:59:48+00:00","description":"Death Caf\u00e9 Oct.\u00a020\u00a0 BAR HARBOR\u2014 MDI Hospital's palliative care advisory committee will hold a Death Caf\u00e9 on Oct. 20 from 6-7:30 p.m. over Zoom.\u00a0 Death","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.mdislander.com/maine-news/island-and-beyond-briefs"]}]},{"@type":"Article","@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#article","isPartOf":{"@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#webpage"},"author":{"@id":"https://www.mdislander.com/#/schema/person/d915ad54e57039ea145f2ab545476999"},"headline":"Island (and beyond) Briefs","datePublished":"2020-10-16T13:24:23+00:00","dateModified":"2020-10-16T13:59:48+00:00","mainEntityOfPage":{"@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#webpage"},"commentCount":0,"publisher":{"@id":"https://www.mdislander.com/#organization"},"image":{"@id":"https://www.mdislander.com/maine-news/island-and-beyond-briefs#primaryimage"},"keywords":"Bar Harbor,Ellsworth,Hancock,Northeast Harbor,Thomaston","articleSection":"News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.mdislander.com/maine-news/island-and-beyond-briefs#respond"]}]},{"@type":"Person","@id":"https://www.mdislander.com/#/schema/person/d915ad54e57039ea145f2ab545476999","name":"Guest","image":{"@type":"ImageObject","@id":"https://www.mdislander.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/42aca01709e48eaba90ce4df8cc48ed6?s=96&d=blank&r=g","caption":"Guest"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Feed" href="https://www.mdislander.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Comments Feed" href="https://www.mdislander.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Island (and beyond) Briefs Comments Feed" href="https://www.mdislander.com/maine-news/island-and-beyond-briefs/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mdislander.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='aqpb-view-css-css'  href='https://www.mdislander.com/wp-content/themes/original/page-builder/assets/css/aqpb-view.css?ver=1602907593' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.mdislander.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://www.mdislander.com/wp-content/plugins/column-shortcodes//assets/css/shortcodes.css?ver=1.0.1' type='text/css' media='all' />
<style id='dcl-front-style-dummy-inline-css' type='text/css'>
#dcl_btn_container{text-align: center;margin-top:10px;margin-bottom:10px}
</style>
<link rel='stylesheet' id='genericons-css'  href='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/css/genericons/genericons.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='ts_fab_css-css'  href='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/css/ts-fab.css?ver=2.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='zsfw-style-css'  href='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='zsfw-slider-style-css'  href='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/jquery.bxslider.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto-Slab-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='Roboto-Condensed-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.mdislander.com/wp-content/themes/original/css/font-awesome.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icon-css'  href='https://www.mdislander.com/wp-content/themes/original/css/weather-icons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://www.mdislander.com/wp-content/themes/original/css/flexslider.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-tab-css'  href='https://www.mdislander.com/wp-content/themes/original/css/flexslider-tab.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='superfish-css'  href='https://www.mdislander.com/wp-content/themes/original/css/megafish.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='framework-css'  href='https://www.mdislander.com/wp-content/themes/original/css/framework.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://www.mdislander.com/wp-content/themes/origmag-mdi/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='print-css'  href='https://www.mdislander.com/wp-content/themes/original/css/print.css?ver=5.4.2' type='text/css' media='print' />
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/fanciest-author-box/js/ts-fab.js?ver=2.0.8'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/smugmug-feed.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/smugmug-feed-widget/jquery.bxslider.js?ver=5.4.2'></script>
<link rel='https://api.w.org/' href='https://www.mdislander.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mdislander.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mdislander.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.mdislander.com/?p=84921' />
<link rel="alternate" type="application/json+oembed" href="https://www.mdislander.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mdislander.com%2Fmaine-news%2Fisland-and-beyond-briefs" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mdislander.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mdislander.com%2Fmaine-news%2Fisland-and-beyond-briefs&#038;format=xml" />
<style>.ts-fab-wrapper .ts-fab-list li a { background-color:#e9e9e9; border: 1px solid #e9e9e9; color: #333; } .ts-fab-wrapper .ts-fab-list li.active a { background-color: #333; border: 1px solid #333; color: #fff; }.ts-fab-wrapper .ts-fab-tab.visible-tab { background-color: #f9f9f9; border: 2px solid #333; color: #555; }</style>
		<!-- GA Google Analytics @ https://m0n.co/ga -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-55634975-4', 'auto');
			ga('send', 'pageview');
		</script>

	<style type="text/css">body{ background-color: #eeeeee}header#masthead .prl-header-logo,button, input[type=submit], input[type=button], a.prl-button,.prl-badge,.page_navi li.current span,.prl-accordion section.active a.head,.prl-nav-dropdown a:hover, .widget_newsletter { background-color:#00829b;}a,.prl-block-title, .prl-block-title a, .prl-archive-title,.prl-archive-title a,#footer .prl-block-title a,.comment-reply-title,#footer .prl-block-title,.twitter_widget a,.sf-menu > li.current-menu-item > a,.sf-menu > li.current_page_item > a,.sf-menu > li.current-menu-ancestor > a,.sf-menu > li.current-menu-parent > a, .sf-menu > li:hover > a,.sf-menu > li.sfHover > a { color:#00829b;}.page_navi li.current span, #sliderTab .slider_content .prl-article-meta{ border-color:#00829b;}h1,h2,h3,h4,h5,h6{font-family: "Roboto Condensed", Arial, Helvetica, sans-serif;}div.eai-scores {
padding-left: 20px;
padding-right: 20px;
}

div.eai-scores ul {
list-style: none;
padding-left: 0px;
padding-bottom: 4px;
font-size: .9em;
}

div.eai-scores li {
padding-left: 11px;
font-weight: bold;
font-size: 1.2em;
}

div.eai-scores p {
padding-bottom: 0px;
margin-bottom: 2px;
color: teal;
}

div.eai-scores h3.prl-article-title {
display: none;
}</style>		<meta name="thumbnail" content="https://www.mdislander.com/wp-content/uploads/sites/5/2020/10/Island-map-WEB-1024x683.jpg"><meta property="og:image" content="https://www.mdislander.com/wp-content/uploads/sites/5/2020/10/Island-map-WEB-1024x683.jpg"></head>
<body class="post-template-default single single-post postid-84921 single-format-standard site-boxed">
<div id="topbar"></div>
<div class="site-wrapper">
    <!--<div class="prl-container">-->

		<header id="masthead" class="clearfix">
			<div class="prl-container">
												<div class="prl-nav-flip-top hidden-tablet">
					
					<div id="search_form-top" class="nav_search">
						<form class="prl-search" action="https://www.mdislander.com">
							<input type="text" id="s" name="s" value="" placeholder="&#xF002;" class="nav_search_input" />
													</form>
					</div>

				</div>
												<nav id="topnav" class="hidden-tablet">
					<div class="nav-wrapper clearfix">
					<ul id="top-menu" class="sf-menu eai-menu"><li id="menu-item-1574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1574"><a target="_blank" rel="noopener noreferrer" href="http://www.downeastmaine.com/classifieds/helpwanted/">Jobs</a></li>
<li id="menu-item-1575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1575"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li>
<li id="menu-item-1576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1576"><a target="_blank" rel="noopener noreferrer" href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li>
<li id="menu-item-52385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52385"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li>
<li id="menu-item-23064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23064"><a href="http://www.acadiavisitor.com/">Acadia Visitor</a></li>
<li id="menu-item-31935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31935"><a href="https://mountdesertislander-me.newsmemory.com">Digital Edition</a></li>
<li id="menu-item-57478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57478"><a href="https://www.ellsworthamericaninc.com/contact-us/contact-advertising/">Advertise</a></li>
</ul>					</div>
				</nav>

			</div> 			<div class="prl-container top-header">
				<div class="masthead-bg clearfix">
				<div class="prl-header-logo"><a href="https://www.mdislander.com" title="Mount Desert Islander"><img src="https://www.mdislander.com/wp-content/uploads/sites/5/2014/09/islander_logo_teal.png" alt="Mount Desert Islander" /></a>
				</div>
				<div class="prl-header-mid">
										<span class="prl-header-time"><a href="https://www.downeastmaine.com/calendar/events/today/"><i class="fa fa-calendar"></i>Saturday - Oct 17, 2020</a></span>
										<ul class="ea-technav-login ea-leaky-login"><li><a id="ta_account_button" onclick="ta_account()" >~</a></li></ul>				</div>
				<div class="prl-header-social">
					<a href="https://www.facebook.com/mdislander" class="fa fa-facebook" title="Facebook" target="_blank"></a>																				                                        <a href="https://www.youtube.com/user/mountdesertislander" class="youtube-pic" title="Youtube"><img src="https://www.mdislander.com/wp-content/themes/origmag-mdi/images/youtube.jpg"></a>				</div><!-- end of header social -->
			 </div>
			</div>
		</header>
		<nav id="nav" class="prl-navbar" role="navigation">
			<div class="prl-container">
				<div class="nav-wrapper clearfix centered-menu">
				<ul id="sf-menu" class="sf-menu"><li id="menu-item-35813" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-35813"><a href="https://www.mdislander.com">Home</a></li>
<li id="menu-item-35814" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-35814"><a href="https://www.mdislander.com/maine-news">News</a>
<ul class="sub-menu">
	<li id="menu-item-35824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35824"><a href="https://www.mdislander.com/maine-news/waterfront">Maritime</a></li>
	<li id="menu-item-49206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49206"><a href="https://www.mdislander.com/maine-news/cops">Cops &#038; Courts</a></li>
	<li id="menu-item-49207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49207"><a href="https://www.mdislander.com/maine-news/education-news">Education</a></li>
	<li id="menu-item-49209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49209"><a href="https://www.mdislander.com/maine-news/political-news">Politics</a></li>
	<li id="menu-item-49208" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49208"><a href="https://www.mdislander.com/maine-news/environment">Environment</a></li>
</ul>
</li>
<li id="menu-item-36251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36251"><a href="https://www.mdislander.com/mdi-sports">Sports</a></li>
<li id="menu-item-35817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35817"><a href="https://www.mdislander.com/living">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-49210" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49210"><a href="https://www.mdislander.com/living/arts-a-living">Arts &#038; living</a></li>
	<li id="menu-item-49214" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49214"><a href="https://www.mdislander.com/living/living-entertainment">Entertainment</a></li>
	<li id="menu-item-49211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49211"><a href="https://www.mdislander.com/living/auto-reviews">Auto reviews</a></li>
	<li id="menu-item-49213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49213"><a href="https://www.mdislander.com/living/columnists/nature">Nature</a></li>
</ul>
</li>
<li id="menu-item-35818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35818"><a href="https://www.mdislander.com/opinions">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-49218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49218"><a href="https://www.mdislander.com/opinions/editorials">Editorials</a></li>
	<li id="menu-item-49217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49217"><a href="https://www.mdislander.com/opinions/commentary">Commentary</a></li>
	<li id="menu-item-49219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49219"><a href="https://www.mdislander.com/opinions/letters-to-the-editor">Letters to the editor</a></li>
	<li id="menu-item-49216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49216"><a href="https://www.mdislander.com/opinions/columnists-opinions/jill-goldthwait">State of Maine</a></li>
</ul>
</li>
<li id="menu-item-57079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57079"><a href="https://www.mdislander.com/obituary">Obituaries</a></li>
<li id="menu-item-35822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35822"><a href="http://www.mainenotices.com/">Public Notices</a></li>
<li id="menu-item-35823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35823"><a href="https://www.downeastmaine.com/calendar/events/category/events/">Calendar</a></li>
<li id="menu-item-56315" class="mdi-menu-button menu-item menu-item-type-custom menu-item-object-custom menu-item-56315"><a href="https://www.mdislander.com/subscriptions">SUBSCRIBE</a></li>
</ul>
				<div class="nav_menu_control"><a href="#" data-prl-offcanvas="{target:'#offcanvas'}"><span class="prl-nav-toggle prl-nav-menu"></span><span class="nav_menu_control_text"></span></a>
				</div>
								<div class="prl-nav-flip show-tablet">
					
					<div id="search_form" class="nav_search show-tablet">
						<form class="prl-search" action="https://www.mdislander.com">
							<input type="text" id="s" name="s" value="" placeholder="&#xF002;" class="nav_search_input" />
													</form>
					</div>

				</div>
				
				</div>
			</div>
		</nav>

		<script>
			var $ = jQuery.noConflict();
			$(document).ready(function() {
				var example = $('#sf-menu').superfish({
					delay:       100,
					animation:   {opacity:'show',height:'show'},
					dropShadows: false,
					autoArrows:  false
				});
			});

		</script>

    <!--</div>-->
	<div id="offcanvas" class="prl-offcanvas">
	<div class="prl-offcanvas-bar">
		<nav class="side-nav">
		<ul id="nav-list" class="nav-list"><li id="menu-item-1579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1579"><a href="https://www.mdislander.com/">Home</a></li>
<li id="menu-item-82248" class="mdi-menu-button menu-item menu-item-type-custom menu-item-object-custom menu-item-82248"><a href="https://www.mdislander.com/subscriptions">Subscribe</a></li>
<li id="menu-item-1987" class="eai-menu-top menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1987"><a href="/maine-news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-1620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1620"><a href="https://www.mdislander.com/maine-news/cops">Cops &#038; Courts</a></li>
	<li id="menu-item-2006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2006"><a href="https://www.mdislander.com/maine-news/waterfront">Maritime</a></li>
	<li id="menu-item-1655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1655"><a href="https://www.mdislander.com/maine-news/education-news">Education</a></li>
	<li id="menu-item-1656" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1656"><a href="https://www.mdislander.com/maine-news/business-news">Business</a></li>
	<li id="menu-item-1657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1657"><a href="https://www.mdislander.com/maine-news/health-news">Health</a></li>
</ul>
</li>
<li id="menu-item-2015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2015"><a href="https://www.mdislander.com/mdi-sports">Sports</a></li>
<li id="menu-item-1599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1599"><a href="https://www.mdislander.com/living">Lifestyle</a></li>
<li id="menu-item-2018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2018"><a href="https://www.mdislander.com/opinions">Opinion</a></li>
<li id="menu-item-57082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57082"><a href="https://www.mdislander.com/obituary">Obituaries</a></li>
<li id="menu-item-1600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1600"><a target="_blank" rel="noopener noreferrer" href="http://www.mainenotices.com/">Public Notices</a></li>
<li id="menu-item-1610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1610"><a href="https://www.downeastmaine.com/calendar/events/category/events/">Calendar</a></li>
<li id="menu-item-32512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32512"><a href="https://mountdesertislander-me.newsmemory.com">Digital edition</a></li>
<li id="menu-item-52386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52386"><a href="http://www.downeastmaine.com/classifieds/helpwanted/">Help Wanted</a></li>
<li id="menu-item-52387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52387"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li>
<li id="menu-item-52388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52388"><a href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li>
<li id="menu-item-52389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52389"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li>
</ul>		</nav>
</div></div><div class="prl-container">
    <div class="prl-grid prl-grid-divider">
    	<div id="single-top-ad" class=prl-span-12><div class="widget-odd widget-last widget-first widget-1 eai-ad-container eai-ad-across prl-span-12"><div id="bs_zones-10" class=" bs_zones ad-container"><div><broadstreet-zone zone-id="43389" keywords="not_home_page,not_landing_page,is_article_page,maine-news,island-and-beyond-briefs,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div></div></div>        <section id="main" class="prl-span-9"> <!-- single -->
        			   		   <article id="post-84921" class="article-single post-84921 post type-post status-publish format-standard has-post-thumbnail hentry category-maine-news tag-bar-harbor tag-ellsworth tag-hancock tag-northeast-harbor tag-thomaston">
		   		<meta itemprop="image" content="https://www.mdislander.com/wp-content/uploads/sites/5/2020/10/Island-map-WEB.jpg"></meta>								   <h1><a href="https://www.mdislander.com/maine-news/island-and-beyond-briefs" rel="bookmark" title="Island (and beyond) Briefs">Island (and beyond) Briefs</a></h1>
			   <hr class="prl-grid-divider">
				<div class ="single-meta">
			   			<div class="prl-article-meta">
		<span>October 16, 2020</span>						on <a href="https://www.mdislander.com/maine-news" rel="category tag">News</a> 
	</div>

<ul class="prl-list prl-list-sharing">
	<li><a href="http://www.facebook.com/share.php?u=https://www.mdislander.com/maine-news/island-and-beyond-briefs" target="_blank"><i class="fa fa-facebook-square"></i> </a></li>
	<li><a href="http://twitter.com/home?status=Island (and beyond) Briefs - https://www.mdislander.com/maine-news/island-and-beyond-briefs" target="_blank"><i class="fa fa-twitter-square"></i> </a></li>
		<li><a href="http://pinterest.com/pin/create/button/?url=https://www.mdislander.com/maine-news/island-and-beyond-briefs&media=" class="pin-it-button" count-layout="horizontal" onClick="javascript:window.open(this.href,&#39;&#39;, &#39;menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=320,width=620&#39;);return false;"><i class="fa fa-pinterest-square"></i></a></li>
	<li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.mdislander.com/maine-news/island-and-beyond-briefs&title=Island (and beyond) Briefs" target="_blank"><i class="fa fa-linkedin-square"></i></a></li>
	<li><a href="/cdn-cgi/l/email-protection#053a7670676f606671384c7669646b61252d646b612567607c6a6b612c2547776c60637623676a617c386d717175763f2a2a7272722b68616c7669646b6160772b666a682a68646c6b60286b6072762a6c7669646b6128646b612867607c6a6b612867776c606376" target="_blank"><i class="fa fa-envelope"></i></a></li>
	<li><a href="#" onclick="window.print();" id="print-page" ><i class="fa fa-print"></i></a></li>
</ul>

				</div>
			   <hr class="prl-grid-divider">
			   <div class="prl-grid">
					<div class="prl-span-12 prl-span-flip">
						<div class="prl-entry-content clearfix">

						                  
               <p><strong>Death Café Oct. 20 </strong></p>
<p><strong>BAR HARBOR</strong><span data-contrast="none">—</span><span data-contrast="auto"> MDI Hospital&#8217;s palliative care advisory committee will hold a Death Café on Oct. 20 from 6-7:30 p.m. over Zoom. </span></p>
<p><span data-contrast="auto">Death Café is an international movement that provides an opportunity for people, often strangers, to gather (virtually) and examine issues surrounding life and death in a relaxed, open, safe atmosphere. There is no agenda or objectives. Death </span><span data-contrast="auto">Café </span><span data-contrast="auto">is not a bereavement or support group, but rather a forum for open </span><span data-contrast="auto">and </span><span data-contrast="auto">respectful discussion about a topic people often find difficult.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="auto">For more information, visit </span><a href="http://deathcafe.com/"><span data-contrast="none">deathcafe.com</span></a><span data-contrast="auto">. For the Zoom link and questions about this event, contact Carla </span><span data-contrast="auto">Tanguay</span><span data-contrast="auto"> at </span><a href="/cdn-cgi/l/email-protection#226143504e436e76434c4557435b62454f434b4e0c414d4f"><span data-contrast="none"><span class="__cf_email__" data-cfemail="f6b597849a97baa297989183978fb6919b979f9ad895999b">[email&#160;protected]</span></span></a><span data-contrast="auto"> or 812-8662. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<div class="eai-ad-container eai-ad-incontent"><broadstreet-zone zone-id="77225" keywords="not_home_page,not_landing_page,is_article_page,maine-news,island-and-beyond-briefs,post" soft-keywords="true" zone-alias=""></broadstreet-zone>
<broadstreet-zone zone-id="77226" keywords="not_home_page,not_landing_page,is_article_page,maine-news,island-and-beyond-briefs,post" soft-keywords="true" zone-alias="zzz"></broadstreet-zone></div><p><strong>Bulky waste curbside pickup </strong></p>
<p><span data-contrast="auto"><strong>BAR HARBOR</strong> </span><span data-contrast="none">—</span><span data-contrast="auto"> </span><span data-contrast="auto">The Town Council has adopted a plan to assist residents who do not have the means of transporting bulky waste. Bar Harbor residents can arrange for </span><span data-contrast="auto">curbside</span><span data-contrast="auto"> pickup by paying a $15 fee per item at the Finance Office in the municipal building. Residents will be contacted by the Highway Division to arrange a pickup date. The </span><span data-contrast="auto">remaining </span><span data-contrast="auto">dates are Oct</span><span data-contrast="auto">.</span><span data-contrast="auto"> </span><span data-contrast="auto">19 and 26. Instructions will be available at the time the appointment is made.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="auto">An alternative will be available on Friday, Oct</span><span data-contrast="auto">.</span><span data-contrast="auto"> 30, between 8 </span><span data-contrast="auto">a.m.</span><span data-contrast="auto"> and 3 </span><span data-contrast="auto">p.m.</span><span data-contrast="auto">, and Saturday, Oct</span><span data-contrast="auto">.</span><span data-contrast="auto"> 31, between 8</span><span data-contrast="auto">-11:45 a.m.</span><span data-contrast="auto"> at the </span><span data-contrast="auto">r</span><span data-contrast="auto">ecycling </span><span data-contrast="auto">c</span><span data-contrast="auto">enter on White Spruce Road. </span><span data-contrast="auto">Only </span><span data-contrast="auto">Bar Harbor residents may take bulky wastes and appliances to the </span><span data-contrast="auto">r</span><span data-contrast="auto">ecycling </span><span data-contrast="auto">c</span><span data-contrast="auto">enter</span><span data-contrast="auto"> free of charge</span><span data-contrast="auto">. Brush will </span><span data-contrast="auto">not</span><span data-contrast="auto"> be </span><span data-contrast="auto">accepted,</span><span data-contrast="auto"> and n</span><span data-contrast="auto">o commercial haulers will be allowed to dump. Violators are subject to charges incurred by the </span><span data-contrast="auto">t</span><span data-contrast="auto">own for disposal of outside wastes.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p>&nbsp;</p>
<p><strong>Permit granted </strong></p>
<p><span data-contrast="auto"><strong>BAR HARBOR</strong>&#8212; A Special Amusement permit renewal application for Jack Russell’s Steak</span><span data-contrast="auto">h</span><span data-contrast="auto">ouse </span><span data-contrast="auto">and Brewery </span><span data-contrast="auto">was presented to the Bar Harbor Town Council on Oct</span><span data-contrast="auto">.</span><span data-contrast="auto"> 6. Councilor’s reviewed and approved the annual application from owner Tom St.Germain’s for a Class 3a permit, which can include three or more musicians with mechanical amplification to play at the restaurant located at 102 Eden Street. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559740&quot;:276}"> </span></p>
<p>&nbsp;</p>
<p><strong>Water rates remain </strong></p>
<p><span data-contrast="none"><strong>BAR HARBOR</strong>&#8212; For the fifth straight year, residents and business owners in Bar Harbor will see no change to their annual water bill. On Oct. 6, town councilors approved the Bar Harbor Water Department’s budget, which did not contain a rate increase. The town has 1,768 metered </span><span data-contrast="none">users</span><span data-contrast="none"> and the average residential user pays $76.17 for the first 1,200 cubic feet through a 5/8-inch meter. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559738&quot;:260,&quot;335559739&quot;:260,&quot;335559740&quot;:276}"> </span></p>
<p>&nbsp;</p>
<p><strong>Science café </strong></p>
<p><span data-contrast="none"><strong>BAR HARBOR</strong>&#8212;</span><span data-contrast="none">MDI Bioloigical Laboratory&#8217;s next Science Café Online on Monday, Oct</span><span data-contrast="none">.</span><span data-contrast="none"> 19, at 5</span><span data-contrast="none"> </span><span data-contrast="none">pm will explore the ecological and social drivers of the spread of Deer tick populations and rise in tick-borne diseases in Maine.</span><span data-ccp-props="{&quot;134233117&quot;:true,&quot;134233118&quot;:true,&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="none">Presenter Dr. Allison Gardner is a medical entomologist and an </span><span data-contrast="none">Assistant Professor in the School of Biology and Ecology at University of Maine.</span><span data-ccp-props="{&quot;134233117&quot;:true,&quot;134233118&quot;:true,&quot;201341983&quot;:0,&quot;335559740&quot;:240}"> </span></p>
<p><span data-contrast="none">Registration is required to receive the online event link and can be completed at </span><a href="http://mdibl.org/events"><span data-contrast="none">mdibl.org/events.</span></a></p>
<p>&nbsp;</p>
<p><strong>Winter workshop goes virtual </strong></p>
<p><span data-contrast="none"><strong>NORTHEAST HARBOR</strong>&#8211;The Northeast Harbor Library has adapted its annual winter workshops to be virtual. This year, participants will register with the library, receive a kit of materials and follow along with a virtual tutorial to make something together. </span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:240}"> </span></p>
<p><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:240}"> </span><span data-contrast="none">In the first workshop, participants will make leaf mandala printed handkerchiefs using colorful fall leaves and a hammer to transfer the pigments of the leaves to fabric. The resulting project will be a botanical-inspired handkerchief.</span></p>
<p><span data-contrast="none">This workshop will be on Wednesday, Oct. 28 at 5 p.m. Registration is limited to 15, first come first served. To register, contact the library at (207) 276 3333, </span><a href="/cdn-cgi/l/email-protection#542035383f203b2127143a313c383d362635262d7a3b2633"><span data-contrast="none"><span class="__cf_email__" data-cfemail="3642575a5d425943457658535e5a5f544457444f18594451">[email&#160;protected]</span></span></a><span data-contrast="none">, or stop by. These events are free and appropriate for all ages. Contact the library with questions.</span></p>
<p>&nbsp;</p>
<p><strong>Ellsworth library hosting online author talk </strong></p>
<p><b><span data-contrast="auto">ELLSWORTH</span></b><span data-contrast="auto"> — </span><span data-contrast="auto">As part of </span><span data-contrast="auto">the Ellsworth Public Library’s</span><span data-contrast="auto"> Maine 200 series, author Joseph Owen will discuss</span><span data-contrast="auto"> </span><span data-contrast="auto">“</span><span data-contrast="auto">This Day in Maine</span><span data-contrast="auto">” in an online talk on</span><span data-contrast="auto"> Thursday, Oct. 29, at 6 p.m.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="auto">While first thoughts of Maine are often about vacations, moose, lobsters and lighthouses, the state also has a rich history. This book highlights some of Maine’s heroes, inventors, athletes, famous and infamous people as well as some highlights and lowlights of Maine history.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="auto">The e</span><span data-contrast="auto">vent is free to attend</span><span data-contrast="auto">,</span><span data-contrast="auto"> but Zoom </span><span data-contrast="auto">r</span><span data-contrast="auto">egistration</span><span data-contrast="auto"> is</span><span data-contrast="auto"> required.</span><span data-contrast="auto"> Registration can be done at </span><a href="https://lib.us15.list-manage.com/track/click?u=873a5125f3ba8dc8026b0e0d3&amp;id=c6921fb1e1&amp;e=4406218424"><span data-contrast="auto">https://tinyurl.com/ThisDayinMaine</span></a><span data-contrast="auto">.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="auto">For more information, call the library at 667-6363.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><b><span data-contrast="none">Ride for a cure</span></b><span data-ccp-props="{&quot;335551550&quot;:2,&quot;335551620&quot;:2}"> </span></p>
<p><b><span data-contrast="auto">HANCOCK – </span></b><span data-contrast="auto">Local volunteers are inviting neighbors across Maine to celebrate breast cancer survivors and to help those facing the disease with Ride for a Cure</span><span data-contrast="auto">, </span><span data-contrast="auto">a Hancock-based ATV ride on Sunday, Oct. 18</span><span data-contrast="auto">.</span><span data-ccp-props="{&quot;335559685&quot;:720}"> </span></p>
<p><span data-contrast="auto">Ride for a Cure </span><span data-contrast="auto">will</span><span data-contrast="auto"> include </span><span data-contrast="auto">an ATV</span><span data-contrast="auto"> </span><span data-contrast="auto">decorating contest, bra decorating contest, 50/50 raffle and additional raffle items. </span><span data-contrast="auto">The first 250 paid registrations will receive a Ride for the Cure gaiter</span><span data-contrast="auto">. </span><span data-ccp-props="{&quot;335559685&quot;:720}"> </span></p>
<p><span data-contrast="auto">Participants are encouraged to register in advance at </span><a href="http://hancockcountyrideforacure2020.eventbrite.com/"><span data-contrast="none">hancockcountyrideforacure2020.eventbrite.com</span></a><span data-contrast="auto">. </span><span data-contrast="auto">Registration for the rain or shine event begins at 8 a.m. at Acadia Area </span><span data-contrast="auto">ATV’ers</span><span data-contrast="auto"> Club, 3 Wyman Road, Hancock, and riders will depart at 9 a.m. on the Downeast Sunrise Trail. A stop is planned at Franklin Trading Post where gas and snacks are available for purchase. The ride will end at Amherst General Store at 561 Airline Road. Social distancing guidelines, including wearing face masks, will be followed. </span><span data-contrast="auto">There is a $20 registration fee.</span><span data-contrast="auto"> </span><span data-ccp-props="{&quot;335559685&quot;:720}"> </span></p>
<p><span data-contrast="auto">Any questions should be emailed to </span><a href="/cdn-cgi/l/email-protection#94dcf5faf7fbf7ffd7fbe1fae0edc6fdf0f1f2fbe6d5d7e1e6f1d4fbe1e0f8fbfbffbaf7fbf9"><span data-contrast="none"><span class="__cf_email__" data-cfemail="9dd5fcf3fef2fef6def2e8f3e9e4cff4f9f8fbf2efdcdee8eff8ddf2e8e9f1f2f2f6b3fef2f0">[email&#160;protected]</span></span></a><span data-contrast="none">. </span><span data-ccp-props="{&quot;335559685&quot;:720}"> </span></p>
<p>&nbsp;</p>
<p><strong>Online discussion on domestic violence </strong></p>
<p><b><span data-contrast="none">BLUE HILL</span></b><span data-contrast="none"> — </span><span data-contrast="none">The </span><span data-contrast="none">Blue Hill Public L</span><span data-contrast="none">ibrary will host an online program about domestic violence on Wednesday</span><span data-contrast="none">,</span><span data-contrast="none"> Oct. 21</span><span data-contrast="none">,</span><span data-contrast="none"> at 6 p.m. in conjunction with Patrisha McLean</span><span data-contrast="none">’</span><span data-contrast="none">s October art exhibit</span><i><span data-contrast="none">, </span></i><span data-contrast="none">“</span><span data-contrast="none">Finding Our Voices: Breaking the Silence of Domestic Abuse.</span><span data-contrast="none">”</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="none">Joining</span><span data-contrast="none"> McLean</span><span data-contrast="none"> in this discussion will be Ellsworth artist and fellow survivor Maegan Graslie and Dorathy Martel, executive director of </span><span data-contrast="none">T</span><span data-contrast="none">he NextStep </span><span data-contrast="none">D</span><span data-contrast="none">omestic </span><span data-contrast="none">V</span><span data-contrast="none">iolence </span><span data-contrast="none">P</span><span data-contrast="none">roject.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="none">NextStep helped both Maegan and Patrisha to safely leave and heal from their domestic violence situations.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="none">“</span><span data-contrast="none">Finding Our Voices: Breaking the Silence of Domestic Abuse</span><span data-contrast="none">”</span><span data-contrast="none"> consists of photo portraits of women from all over the state, all walks of life and all ages who have experienced domestic abuse, plus audio of each telling about the abuse and their journey out of it. The show is on display in the library&#8217;s Britton Gallery and Howard Room through the month of October.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="none">The online program </span><span data-contrast="none">is free and</span><span data-contrast="none"> open to all,</span><span data-contrast="none"> but registration is required to receive the link to join by Zoom.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p><span data-contrast="none">To r</span><span data-contrast="none">egister</span><span data-contrast="none">,</span><span data-contrast="none"> call the library at 374-5515 or </span><span data-contrast="none">use the</span><span data-contrast="none"> online calendar at </span><a href="http://www.bhpl.net/"><span data-contrast="auto">www.bhpl.net</span></a><span data-contrast="auto">.</span><span data-ccp-props="{&quot;201341983&quot;:0,&quot;335559739&quot;:160,&quot;335559740&quot;:259}"> </span></p>
<p>&nbsp;</p>
<p><b><span data-contrast="auto">Coin</span></b><b><span data-contrast="auto"> </span></b><b><span data-contrast="auto">Auction</span></b><span data-ccp-props="{&quot;335551550&quot;:2,&quot;335551620&quot;:2}"> </span></p>
<p><span data-contrast="auto"><strong>THOMASTON</strong>&#8212; On Friday, Oct. 23 at 10 a.m., Thomaston Place Auction Galleries will present over 525 lots of rare U.S. and foreign coins, currency, commemoratives and coin sets sourced from fine private collections and Maine estates. The auction will be held at the Elks Lodge at 210 Rankin Street in Rockland.</span><span data-ccp-props="{&quot;134233117&quot;:true,&quot;134233118&quot;:true,&quot;335559740&quot;:360}"> </span></p>
<p><span data-contrast="auto">Highlighted among the 148 lots of gold coins will be a 1915 gold $20 Saint-Gaudens graded NGC 64+; an 1891 $2.50 Liberty Head gold double die reverse coin graded NGC 65; and an 1891-CC $5 gold Liberty Head coin graded NGC 62+. </span><span data-ccp-props="{&quot;134233117&quot;:true,&quot;134233118&quot;:true,&quot;335559740&quot;:360}"> </span></p>
<p><span data-contrast="auto">There will be a large selection of silver coins such as a complete set of Washington quarters from 1932 to 1998, including proofs from 1968 to 1998 and silver proofs from 1992 to 1998, with most coins MS-65; a 76-piece partial set of Morgan silver dollars; and a 1798 Draped bust Heraldic Eagle dollar.</span><span data-ccp-props="{&quot;134233117&quot;:true,&quot;134233118&quot;:true,&quot;335559740&quot;:360}"> </span></p>
<p><span data-contrast="auto">All lots can be viewed at </span><a href="http://www.thomastonauction.com/"><span data-contrast="none">thomastonauction.com</span></a><span data-contrast="auto">. Seating in the auction hall will be limited to 50 guests, so reservations are recommended. Absentee, telephone and internet bidding will also be available. Call (207) 354-8141 for seat reservations or information. </span></p>

						   						   
						   						</div>
					</div>

			   </div>

		   </article>

		   
		   		   <div id="disqus_thread">
				<div id="dcl_btn_container">
			<button id='dcl_comment_btn' class="">
				Load Comments			</button>
		</div>
	</div>

						        </section>

        <aside id="sidebar" class="prl-span-3">

            <div id="advanced_menu-2" class="icon-home widget-odd widget-first widget-1 eai-two-col-menu widget widget_advanced_menu prl-panel clearfix"><h5 class="prl-block-title">News from &#8230;.</h5><div class="menu-towns-container"><ul id="menu-towns" class="menu"><li id="menu-item-1663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663"><a href="https://www.mdislander.com/bar-harbor">Bar Harbor</a></li>
<li id="menu-item-1660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1660"><a href="https://www.mdislander.com/mount-desert">Mount Desert</a></li>
<li id="menu-item-1662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1662"><a href="https://www.mdislander.com/southwest-harbor">Southwest Harbor</a></li>
<li id="menu-item-1661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1661"><a href="https://www.mdislander.com/tremont">Tremont</a></li>
<li id="menu-item-2082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2082"><a href="https://www.mdislander.com/trenton">Trenton</a></li>
<li id="menu-item-2083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2083"><a href="https://www.mdislander.com/cranberry-isles">Cranberry Isles</a></li>
<li id="menu-item-2084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2084"><a href="https://www.mdislander.com/frenchboro">Frenchboro</a></li>
<li id="menu-item-2085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2085"><a href="https://www.mdislander.com/swans-island">Swan&#8217;s Island</a></li>
</ul></div></div><div id="bs_zones-5" class="widget-even widget-last widget-2 eia-right-rail eai-ad-container eai-ad-right eai-ad-300w widget bs_zones prl-panel clearfix"><div><broadstreet-zone zone-id="76192" keywords="not_home_page,not_landing_page,is_article_page,maine-news,island-and-beyond-briefs,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div>	
	

        </aside>
    </div>
</div>


	<footer id="footer">
		<div id="over_footer_wrap" ><div id="bs_zones-2" class="widget-odd widget-first widget-1  bs_zones eai-overfooter-container"><div><broadstreet-zone zone-id="66948" keywords="not_home_page,not_landing_page,is_article_page,maine-news,island-and-beyond-briefs,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="text-24" class="widget-even widget-last widget-2  widget_text eai-overfooter-container">			<div class="textwidget"><p style="padding-top: 20px; text-align: center;">Advertise your business here. Call Kelley Wescott at (207) 667-2576 or send an <a href="/cdn-cgi/l/email-protection#f8938f9d8b9b978c8cb89d94948b8f978a8c9099959d8a919b9996d69b9795"> email <i class="fa fa-envelope-o" aria-hidden="true"></i></a>.</p>
</div>
		</div></div>				<div class="footer-widget">
			<div class="prl-container">
				<div class="prl-grid prl-grid-divider">
										<div class="prl-span-3">
						<div id="text-11" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Our Websites</h5>			<div class="textwidget"><center><a href="//www.ellsworthamerican.com">EllsworthAmerican.com</a></center>
<center><a href="//www.mdislander.com">MDIslander.com</a></center><center><a href="//www.ellsworthamericaninc.com">About Us</a></center>
<center><a href="//www.downeastmaine.com/calendar">Calendar</a></center>
<center><a href="//www.downeastmaine.com/classifieds/helpwanted/" target="_blank" rel="noopener noreferrer">Help Wanted</a></center>
<center><a href="//www.downeastmaine.com/classifieds/rentals/" target="_blank" rel="noopener noreferrer">Rental Listings</a></center>
<center><a href="//www.downeastmaine.com/classifieds/realestate/">Real Estate</a></center>
<center><a href="//ellsworthamerican.smugmug.com/The-Ellsworth-American" target="_blank" rel="noopener noreferrer">View & Purchase Photos</a></center></div>
		</div>					</div>
										<div class="prl-span-3">
						<div id="text-12" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Send Us Your&#8230;</h5>			<div class="textwidget"><center><a href="//www.ellsworthamericaninc.com/submit-a-wedding-engagement-or-anniversary/">Submit a wedding or engagement</a></center>
<center><a href="//www.ellsworthamericaninc.com/obituaries/">Submit an obituary</a></center>
<center><a href="//www.ellsworthamericaninc.com/submit-a-photo/">Submit a photo</a></center>
<center><a href="//www.ellsworthamericaninc.com/submit-news/">Submit news</a></center>
<center><a href="//www.downeastmaine.com/calendar/events/community/add">Submit a calendar event</a></center>
<center><a href="//www.ellsworthamericaninc.com./submit-a-cancellation/">Submit cancellation or closing</a></center>
<center><a href="https://www.ellsworthamericaninc.com/advertise-with-us/classified-ads/" >Submit a classified ad</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/mount-desert-islander-letter-to-the-editor/">Letters to the Editor</a></center></div>
		</div>					</div>
										<div class="prl-span-3">
						<div id="text-13" class="widget-odd widget-last widget-first widget-1 widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Contact</h5>			<div class="textwidget"><center><a href="//www.ellsworthamericaninc.com/contact-us/contact-advertising/">Advertising</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-the-ellsworth-american-newsroom/">American News</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-mount-desert-islander-newsroom/">Islander News</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-subscriptions/">Circulation</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-accounting/">Accounting</a></center>
<center><a href="//www.ellsworthamericaninc.com/contact-us/contact-internet/">Internet Services</a></center>
<center><a href="//www.mdislander.com/reporters-editors">News Team</a></center>
<center><a href="//www.reachmaine.com/contact/">Reach Maine Marketing</a></center>
<center><a href="http://www.mdislander.com/contact-us">Contact Us</a></center></div>
		</div>					</div>
										<div class="prl-span-3">
						<div id="nav_menu-2" class="widget-odd widget-last widget-first widget-1 widget widget_nav_menu prl-panel clearfix"><h5 class="prl-block-title">Subscriptions</h5><div class="menu-footer-subscriptions-container"><ul id="menu-footer-subscriptions" class="menu"><li id="menu-item-59889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59889"><a href="//ellsworthamerican-me.newsmemory.com">Access your Ellsworth American digital edition</a></li>
<li id="menu-item-59890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59890"><a href="//mountdesertislander-me.newsmemory.com/">Access your Mount Desert Islander digital edition</a></li>
<li id="menu-item-59891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59891"><a href="http://www.mdislander.com/subscriptions/">Subscribe or Renew</a></li>
<li id="menu-item-59892" class="eai-bright-link menu-item menu-item-type-custom menu-item-object-custom menu-item-59892"><a href="//www.ellsworthamericaninc.com/advertise-with-us/">ADVERTISE</a></li>
</ul></div></div>					</div>
									</div>
			</div>
		</div>
				<div class="copyright">
			<div class="prl-container">
				<div class="left">
					&copy; 2020 by <a href="https://www.mdislander.com">Mount Desert Islander</a> -  All rights reserved. | <a href='http://www.ellsworthamericaninc.com/privacy-policy/'>Privacy Policy</a> | <a href='http://www.ellsworthamericaninc.com/terms-of-use/'>Terms Of Use</a>
				</div>
				<div class="right"><a href="https://www.reachmaine.com">Reach Maine</a></div>
			</div>
		</div><!-- .copyright -->

	</footer><!-- #footer -->

</div><!-- .site-wrapper -->
		<a id="toTop" href="#"><i class="fa fa-long-arrow-up"></i></a>
			<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync="false" type="text/javascript" src="//mountdesertislander-me-pw.newsmemory.com/?meter&amp;v=0"></script>
			<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','maine-news','island-and-beyond-briefs','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["maine-news","island-and-beyond-briefs","post"],"url":"island-and-beyond-briefs"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.watch({});
 });</script><script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/page-builder/assets/js/aqpb-view.js?ver=1602907593'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"mdislander"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"84921 https:\/\/www.mdislander.com\/?p=84921","disqusShortname":"mdislander","disqusTitle":"Island (and beyond) Briefs","disqusUrl":"https:\/\/www.mdislander.com\/maine-news\/island-and-beyond-briefs","postId":"84921"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/plugins/disqus-conditional-load/assets/js/public/embed-count-click.min.js?ver=11.0.5'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/custom.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.placeholder.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/superfish.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.infinitescroll.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/jquery.flexslider-min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-content/themes/original/js/plugins.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.mdislander.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
	<!--<script type='text/javascript'>var axel = Math.random() + '';var a = axel * 10000000000000;document.write('<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/6119/DFPAudiencePixel;ord=' + a + ';dc_seg=745020622?" width=1 height=1 border=0/>');</script>
<noscript><img src="https://pubads.g.doubleclick.net/activity;dc_iu=/6119/DFPAudiencePixel;ord=1;dc_seg=745020622?" width=1 height=1 style="display:none;" border=0/></noscript> -->		</body>
</html>
