<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><head><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto+Slab%7CRoboto+Condensed"/><link rel="stylesheet" href="http://www.mdislander.com/wp-content/cache/min/5/c80d765064427a52a7bbf2ab8b42a2df.css" data-minify="1"/><script data-cfasync="false" type="text/javascript" src="http://cdn.broadstreetads.com/init.js"></script><script src="http://www.mdislander.com/wp-content/cache/min/5/30775da47a48ece2b946b7ee49b75a6f.js" data-minify="1"></script> <meta charset="UTF-8"/><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><link rel="shortcut icon" href="https://www.mdislander.com/wp-content/themes/origmag-ea/images/mid_favicon.ico"> <script data-cfasync="false" type="text/javascript" src="http://mountdesertislander.me.pw.newsmemory.com/include.php?service=onstop"></script> <title>Plant paddle set - Mount Desert Islander</title><meta name="description" content="MOUNT DESERT — Paddlers will learn how to identify and combat invasive aquatic species at Invasive Plant Patrol training at the Somes-Meynell Wildlife Sanc"/><meta name="robots" content="noodp"/><link rel="canonical" href="http://www.mdislander.com/maine-news/plant-paddle-set"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="Plant paddle set - Mount Desert Islander"/><meta property="og:description" content="MOUNT DESERT — Paddlers will learn how to identify and combat invasive aquatic species at Invasive Plant Patrol training at the Somes-Meynell Wildlife Sanc"/><meta property="og:url" content="http://www.mdislander.com/maine-news/plant-paddle-set"/><meta property="og:site_name" content="Mount Desert Islander"/><meta property="article:publisher" content="https://www.facebook.com/mdislander/"/><meta property="article:tag" content="Acadia National Park"/><meta property="article:tag" content="invasive plants"/><meta property="article:tag" content="plant paddle"/><meta property="article:tag" content="Somes-Meynell Wildlife Sanctuary"/><meta property="article:tag" content="Volunteer Lake Monitoring Program"/><meta property="article:section" content="Environment"/><meta property="article:published_time" content="2017-09-06T20:40:04-04:00"/><meta property="article:modified_time" content="2017-09-06T10:44:55-04:00"/><meta property="og:updated_time" content="2017-09-06T10:44:55-04:00"/><meta property="fb:admins" content="100002128785475"/><meta property="og:image" content="http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591-1024x630.jpg"/><meta property="og:image:width" content="1024"/><meta property="og:image:height" content="630"/><link rel="dns-prefetch" href="//maps.googleapis.com"/><link rel="dns-prefetch" href="//fonts.googleapis.com"/><link rel="dns-prefetch" href="//s.w.org"/><link rel="dns-prefetch" href="//cdn.broadstreetads.com"/><link rel="dns-prefetch" href="//www.googletagmanager.com"/><link rel="dns-prefetch" href="//platform.twitter.com"/><link rel="dns-prefetch" href="//www.google-analytics.com"/><link rel="dns-prefetch" href="//mountdesertislander.me.pw.newsmemory.com"/><link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Feed" href="http://www.mdislander.com/feed"/><link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Comments Feed" href="http://www.mdislander.com/comments/feed"/><link rel="alternate" type="application/rss+xml" title="Mount Desert Islander &raquo; Plant paddle set Comments Feed" href="http://www.mdislander.com/maine-news/plant-paddle-set/feed"/><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel="stylesheet" id="print-css" href="http://www.mdislander.com/wp-content/themes/original/css/print.css?ver=4.7.5" type="text/css" media="print"/><link rel="https://api.w.org/" href="http://www.mdislander.com/wp-json/"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.mdislander.com/xmlrpc.php?rsd"/><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.mdislander.com/wp-includes/wlwmanifest.xml"/><link rel="shortlink" href="http://www.mdislander.com/?p=53916"/><link rel="alternate" type="application/json+oembed" href="http://www.mdislander.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.mdislander.com%2Fmaine-news%2Fplant-paddle-set"/><link rel="alternate" type="text/xml+oembed" href="http://www.mdislander.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.mdislander.com%2Fmaine-news%2Fplant-paddle-set&#038;format=xml"/><style>.ts-fab-wrapper .ts-fab-list li
a{background-color:#e9e9e9;border:1px
solid #e9e9e9;color:#333}.ts-fab-wrapper .ts-fab-list li.active
a{background-color:#333;border:1px
solid #333;color:#fff}.ts-fab-wrapper .ts-fab-tab.visible-tab{background-color:#f9f9f9;border:2px
solid #333;color:#555}</style><style id="ubermenu-custom-generated-css">.ubermenu-main{max-width:1050px}.ubermenu.ubermenu-main{background:none;border:none;box-shadow:none}.ubermenu.ubermenu-main .ubermenu-item-level-0>.ubermenu-target{border:none;box-shadow:none}.ubermenu.ubermenu-main.ubermenu-horizontal .ubermenu-submenu-drop.ubermenu-submenu-align-left_edge_bar, .ubermenu.ubermenu-main.ubermenu-horizontal .ubermenu-submenu-drop.ubermenu-submenu-align-full_width{left:0}.ubermenu.ubermenu-main.ubermenu-horizontal .ubermenu-item-level-0.ubermenu-active > .ubermenu-submenu-drop, .ubermenu.ubermenu-main.ubermenu-horizontal:not(.ubermenu-transition-shift) .ubermenu-item-level-0>.ubermenu-submenu-drop{margin-top:0}.ubermenu-main .ubermenu-item-level-0>.ubermenu-target{font-size:14px;text-transform:uppercase}.ubermenu-main .ubermenu-item.ubermenu-item-level-0>.ubermenu-highlight{color:#000}</style> <script data-cfasync="false" type="text/javascript">var gtm4wp_datalayer_name="dataLayer";var dataLayer=dataLayer||[]
var gtm4wp_scrollerscript_debugmode=false;var gtm4wp_scrollerscript_callbacktime=100;var gtm4wp_scrollerscript_readerlocation=150;var gtm4wp_scrollerscript_contentelementid="content";var gtm4wp_scrollerscript_scannertime=60;var google_tag_params={"pageTitle":"Plant paddle set - Mount Desert Islander","pagePostType":"post","pagePostType2":"single-post","pageCategory":["environment","maine-news"],"pageAttributes":["acadia-national-park","invasive-plants","plant-paddle","somes-meynell-wildlife-sanctuary","volunteer-lake-monitoring-program"],"pagePostAuthor":"Islander Staff","pagePostDate":"September 6, 2017","pagePostDateYear":"2017","pagePostDateMonth":"09","pagePostDateDay":"06","browserName":"CommonCrawl","browserVersion":"3.0","browserEngineName":"","browserEngineVersion":"","osName":"","osVersion":"","deviceType":"bot","deviceManufacturer":"","deviceModel":"","postCountOnPage":1,"postCountTotal":1};dataLayer.push({"pageTitle":"Plant paddle set - Mount Desert Islander","pagePostType":"post","pagePostType2":"single-post","pageCategory":["environment","maine-news"],"pageAttributes":["acadia-national-park","invasive-plants","plant-paddle","somes-meynell-wildlife-sanctuary","volunteer-lake-monitoring-program"],"pagePostAuthor":"Islander Staff","pagePostDate":"September 6, 2017","pagePostDateYear":"2017","pagePostDateMonth":"09","pagePostDateDay":"06","browserName":"CommonCrawl","browserVersion":"3.0","browserEngineName":"","browserEngineVersion":"","osName":"","osVersion":"","deviceType":"bot","deviceManufacturer":"","deviceModel":"","postCountOnPage":1,"postCountTotal":1,"google_tag_params":window.google_tag_params});</script> <script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TLWNXT');</script>
<style type="text/css">body{background-color:#eee}header#masthead .prl-header-logo,button, input[type=submit], input[type=button], a.prl-button,.prl-badge,.page_navi li.current span,.prl-accordion section.active a.head,.prl-nav-dropdown a:hover,.widget_newsletter{background-color:#00829b}a,.prl-block-title, .prl-block-title a, .prl-archive-title,.prl-archive-title a,#footer .prl-block-title a,.comment-reply-title,#footer .prl-block-title,.twitter_widget a,.sf-menu>li.current-menu-item>a,.sf-menu>li.current_page_item>a,.sf-menu>li.current-menu-ancestor>a,.sf-menu>li.current-menu-parent>a,.sf-menu>li:hover>a,.sf-menu>li.sfHover>a{color:#00829b}.page_navi li.current span, #sliderTab .slider_content .prl-article-meta{border-color:#00829b}h1,h2,h3,h4,h5,h6{font-family:"Roboto Condensed",Arial,Helvetica,sans-serif}div.eai-scores{padding-left:20px;padding-right:20px}div.eai-scores
ul{list-style:none;padding-left:0px;padding-bottom:4px;font-size: .9em}div.eai-scores
li{padding-left:11px;font-weight:bold;font-size:1.2em}div.eai-scores
p{padding-bottom:0px;margin-bottom:2px;color:teal}div.eai-scores h3.prl-article-title{display:none}</style><script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="http://www.mdislander.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script> <meta name="thumbnail" content="http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591-1024x683.jpg"></head><body class="post-template-default single single-post postid-53916 single-format-standard site-boxed"><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TLWNXT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="topbar"><div class="prl-span-12"><div id="text-17" class=" widget_text topbar"><div class="textwidget"></div></div></div></div><div class="site-wrapper"><header id="masthead" class="clearfix"><div class="prl-container"><div class="prl-nav-flip-top hidden-tablet"><div id="search_form-top" class="nav_search"><form class="prl-search" action="http://www.mdislander.com"> <input type="text" id="s" name="s" value placeholder="&#xF002;" class="nav_search_input"/></form></div></div> <nav id="topnav" class="hidden-tablet"><div class="nav-wrapper clearfix"><ul id="top-menu" class="sf-menu eai-menu"><li id="menu-item-1574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1574"><a target="_blank" href="http://www.downeastmaine.com/classifieds/helpwanted/">Jobs</a></li><li id="menu-item-1575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1575"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li><li id="menu-item-1576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1576"><a target="_blank" href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li><li id="menu-item-52385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52385"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li><li id="menu-item-1577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1577"><a href="http://www.downeastmaine.com/">Business Directory</a></li><li id="menu-item-23064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23064"><a href="http://www.acadiavisitor.com/">Acadia Visitor</a></li><li id="menu-item-43031" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43031"><a href="http://www.mdislander.com/subscriptions">Subscribe</a></li><li id="menu-item-31935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31935"><a href="http://digital.mdislander.com/">Digital Edition</a></li></ul></div> </nav></div><div class="prl-container top-header"><div class="masthead-bg clearfix"><div class="prl-header-logo"><a href="http://www.mdislander.com" title="Mount Desert Islander"><img src="http://www.mdislander.com/wp-content/uploads/sites/5/2014/09/islander_logo_teal.png" alt="Mount Desert Islander"/></a></div><div class="prl-header-mid"> <span class="prl-header-time"><a href="http://www.reachdowneast.com/calendar/events/today/"><i class="fa fa-calendar"></i>Thursday - Sep 07, 2017</a></span><ul class="ea-technav-login ea-leaky-login"><li><a id="ta_account_button" onclick="ta_account()">~</a></li></ul></div><div class="prl-header-social"> <a href="https://www.facebook.com/mdislander" class="fa fa-facebook" title="Facebook" target="_blank"></a> <a href="https://twitter.com/TheMDIslander" class="fa fa-twitter" title="Twitter" target="_blank"></a> <a href="https://www.youtube.com/user/mountdesertislander" class="youtube-pic" title="Youtube"><img src="http://www.mdislander.com/wp-content/themes/origmag-mdi/images/youtube.jpg"></a></div></div> </header> <nav id="nav" class="prl-navbar" role="navigation"><div class="prl-container"><div class="nav-wrapper clearfix centered-menu"><ul id="sf-menu" class="sf-menu"><li id="menu-item-35813" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-35813"><a href="http://www.mdislander.com">Home</a></li><li id="menu-item-35814" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-35814"><a href="http://www.mdislander.com/maine-news">News</a><ul class="sub-menu"><li id="menu-item-35824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35824"><a href="http://www.mdislander.com/maine-news/waterfront">Maritime</a></li><li id="menu-item-49206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49206"><a href="http://www.mdislander.com/maine-news/cops">Cops &#038; Courts</a></li><li id="menu-item-49207" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49207"><a href="http://www.mdislander.com/maine-news/education-news">Education</a></li><li id="menu-item-49209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49209"><a href="http://www.mdislander.com/maine-news/political-news">Politics</a></li><li id="menu-item-49208" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-49208"><a href="http://www.mdislander.com/maine-news/environment">Environment</a></li></ul></li><li id="menu-item-36251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36251"><a href="http://www.mdislander.com/mdi-sports">Sports</a></li><li id="menu-item-35817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35817"><a href="http://www.mdislander.com/living">Lifestyle</a><ul class="sub-menu"><li id="menu-item-49210" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49210"><a href="http://www.mdislander.com/living/arts-a-living">Arts &#038; living</a></li><li id="menu-item-49214" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49214"><a href="http://www.mdislander.com/living/living-entertainment">Entertainment</a></li><li id="menu-item-49211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49211"><a href="http://www.mdislander.com/living/auto-reviews">Auto reviews</a></li><li id="menu-item-49212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49212"><a href="http://www.mdislander.com/living/columnists/ask-carolyn">Ask Carolyn</a></li><li id="menu-item-49213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49213"><a href="http://www.mdislander.com/living/columnists/nature">Nature</a></li><li id="menu-item-49215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49215"><a href="http://www.mdislander.com/horoscope/daily-horoscope">Horoscope</a></li></ul></li><li id="menu-item-35866" class="menu-item menu-item-type-post_type_archive menu-item-object-ea_obit menu-item-35866"><a href="http://www.mdislander.com/obituary">Obituaries</a></li><li id="menu-item-35818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35818"><a href="http://www.mdislander.com/opinions">Opinion</a><ul class="sub-menu"><li id="menu-item-49218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49218"><a href="http://www.mdislander.com/opinions/editorials">Editorials</a></li><li id="menu-item-49217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49217"><a href="http://www.mdislander.com/opinions/commentary">Commentary</a></li><li id="menu-item-49219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49219"><a href="http://www.mdislander.com/opinions/letters-to-the-editor">Letters to the editor</a></li><li id="menu-item-49216" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49216"><a href="http://www.mdislander.com/opinions/columnists-opinions/jill-goldthwait">State of Maine</a></li></ul></li><li id="menu-item-35822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35822"><a href="http://www.reachdowneast.com/public-notices/">Public Notices</a></li><li id="menu-item-35823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35823"><a href="http://www.reachdowneast.com/calendar/events/category/events/">Calendar</a></li></ul><div class="nav_menu_control"><a href="#" data-prl-offcanvas="{target:'#offcanvas'}"><span class="prl-nav-toggle prl-nav-menu"></span><span class="nav_menu_control_text"></span></a></div><div class="prl-nav-flip show-tablet"><div id="search_form" class="nav_search show-tablet"><form class="prl-search" action="http://www.mdislander.com"> <input type="text" id="s" name="s" value placeholder="&#xF002;" class="nav_search_input"/></form></div></div></div></div> </nav> <script>var $=jQuery.noConflict();$(document).ready(function(){var example=$('#sf-menu').superfish({delay:100,animation:{opacity:'show',height:'show'},dropShadows:false,autoArrows:false});});</script> <div id="offcanvas" class="prl-offcanvas"><div class="prl-offcanvas-bar"> <nav class="side-nav"><ul id="nav-list" class="nav-list"><li id="menu-item-1579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1579"><a href="http://www.mdislander.com/">Home</a></li><li id="menu-item-1987" class="eai-menu-top menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1987"><a href="/maine-news/">News</a><ul class="sub-menu"><li id="menu-item-1620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1620"><a href="http://www.mdislander.com/maine-news/cops">Cops &#038; Courts</a></li><li id="menu-item-2006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2006"><a href="http://www.mdislander.com/maine-news/waterfront">Maritime</a></li><li id="menu-item-1655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1655"><a href="http://www.mdislander.com/maine-news/education-news">Education</a></li><li id="menu-item-1656" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1656"><a href="http://www.mdislander.com/maine-news/business-news">Business</a></li><li id="menu-item-1657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1657"><a href="http://www.mdislander.com/maine-news/health-news">Health</a></li></ul></li><li id="menu-item-2015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2015"><a href="http://www.mdislander.com/mdi-sports">Sports</a></li><li id="menu-item-1599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1599"><a href="http://www.mdislander.com/living">Lifestyle</a></li><li id="menu-item-2018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2018"><a href="http://www.mdislander.com/opinions">Opinion</a></li><li id="menu-item-7197" class="menu-item menu-item-type-post_type_archive menu-item-object-ea_obit menu-item-7197"><a href="http://www.mdislander.com/obituary">Obituaries</a></li><li id="menu-item-1600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1600"><a href="http://www.reachdowneast.com/public-notices/">Public Notices</a></li><li id="menu-item-1610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1610"><a href="http://www.reachdowneast.com/calendar/events/category/events/">Calendar</a></li><li id="menu-item-32512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32512"><a href="http://digital.mdislander.com/">Digital edition</a></li><li id="menu-item-52386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52386"><a href="http://www.downeastmaine.com/classifieds/helpwanted/">Help Wanted</a></li><li id="menu-item-52387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52387"><a href="http://www.downeastmaine.com/classifieds/realestate/">Real Estate</a></li><li id="menu-item-52388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52388"><a href="http://www.downeastmaine.com/classifieds/rentals/">Rentals</a></li><li id="menu-item-52389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52389"><a href="http://www.downeastmaine.com/classifieds/">Classifieds</a></li></ul> </nav></div></div><div class="prl-container"><div class="prl-grid prl-grid-divider"><div class="prl-span-12"><div id="text-4" class=" widget_text ad-container"><div class="textwidget"><script data-cfasync="false" type="text/javascript">broadstreet.zone(43390,{responsive:true});</script></div></div></div> <section id="main" class="prl-span-9"> <article id="post-53916" class="article-single post-53916 post type-post status-publish format-standard has-post-thumbnail hentry category-environment category-maine-news tag-acadia-national-park tag-invasive-plants tag-plant-paddle tag-somes-meynell-wildlife-sanctuary tag-volunteer-lake-monitoring-program"><meta itemprop="image" content="http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591.jpg"></meta><div class="single-post-thumbnail "> <img width="1024" height="683" src="http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591.jpg" class="attachment-ea_featuredimg size-ea_featuredimg wp-post-image" alt srcset="http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591.jpg 1024w, http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591-300x200.jpg 300w, http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591-600x400.jpg 600w, http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591-400x267.jpg 400w" sizes="(max-width: 1024px) 100vw, 1024px"/></div><div class="single-post-thumbnail-caption space-bot"><div class="ccfic"><span class="ccfic-text">Milfoil, one of many invasive aquatic plants in Maine. </span> <span class="ccfic-source">PHOTO COURTESY OF THE MAINE DEP</span></div></div><h1><a href="http://www.mdislander.com/maine-news/plant-paddle-set" rel="bookmark" title="Plant paddle set">Plant paddle set</a></h1><hr class="prl-grid-divider"><div class="single-meta"><div class="prl-article-meta"> <span>September 6, 2017</span> on <a href="http://www.mdislander.com/maine-news/environment" rel="category tag">Environment</a>, <a href="http://www.mdislander.com/maine-news" rel="category tag">News</a></div><ul class="prl-list prl-list-sharing"><li><a href="http://www.facebook.com/share.php?u=http://www.mdislander.com/maine-news/plant-paddle-set" target="_blank"><i class="fa fa-facebook-square"></i> </a></li><li><a href="http://twitter.com/home?status=Plant paddle set - http://www.mdislander.com/maine-news/plant-paddle-set" target="_blank"><i class="fa fa-twitter-square"></i> </a></li><li><a href="https://plus.google.com/share?url=http://www.mdislander.com/maine-news/plant-paddle-set" onClick="javascript:window.open(this.href,&#39;&#39;, &#39;menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=320,width=620&#39;);return false;"><i class="fa fa-google-plus-square"></i></a></li><li><a href="http://pinterest.com/pin/create/button/?url=http://www.mdislander.com/maine-news/plant-paddle-set&media=http://www.mdislander.com/wp-content/uploads/sites/5/2017/09/Invasive-milfoil-Maine-DEP-e1504709041591.jpg" class="pin-it-button" count-layout="horizontal" onClick="javascript:window.open(this.href,&#39;&#39;, &#39;menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=320,width=620&#39;);return false;"><i class="fa fa-pinterest-square"></i></a></li><li><a href="http://www.linkedin.com/shareArticle?mini=true&url=http://www.mdislander.com/maine-news/plant-paddle-set&title=Plant paddle set" target="_blank"><i class="fa fa-linkedin-square"></i></a></li><li><a href="/cdn-cgi/l/email-protection#99a6eaecfbf3fcfaeda4c9f5f8f7edb9e9f8fdfdf5fcb9eafcedbffbf6fde0a4f1edede9a3b6b6eeeeeeb7f4fdf0eaf5f8f7fdfcebb7faf6f4b6f4f8f0f7fcb4f7fceeeab6e9f5f8f7edb4e9f8fdfdf5fcb4eafced" target="_blank"><i class="fa fa-envelope"></i></a></li><li><a href="#" onclick="window.print();" id="print-page"><i class="fa fa-print"></i></a></li></ul></div><hr class="prl-grid-divider"><div class="prl-grid"><div class="prl-span-12 prl-span-flip"><div class="prl-entry-content clearfix"><p>MOUNT DESERT — Paddlers will learn how to identify and combat invasive aquatic species at Invasive Plant Patrol training at the Somes-Meynell Wildlife Sanctuary and on Somes Pond on Saturday, Sept. 9. The guided expedition, set for 9 a.m. to noon, will match novices with experienced volunteers.</p><p>Participants will learn how to use field guide keys to help identify suspected invaders, become familiar with common native plants and practice skills needed to be an effective early detector.</p><p>The program is led by the Volunteer Lake Monitoring Program and co-hosted by VLMP, Acadia National Park and Somes-Meynell Wildlife Sanctuary with the goal of more fully understanding the current condition of our lakes. Call 460-9390.</p><div class="prl-span-12"><div class="yarpp-thumbnails-horizontal"><div class="yarpp-related"><h4>Related Posts</h4><ul><li><a href="http://www.mdislander.com/maine-news/invasive-plant-paddle-set" rel="bookmark"> <span class="yarpp-thumbnail"></span><p class="yarpp-thumbnail-title"> Invasive plant paddle is set</p> </a></li><li><a href="http://www.mdislander.com/maine-news/trails-day-event-set" rel="bookmark"> <span class="yarpp-thumbnail"></span><p class="yarpp-thumbnail-title"> Trails Day event set</p> </a></li><li><a href="http://www.mdislander.com/maine-news/forgotten-span-view-sought" rel="bookmark"> <span class="yarpp-thumbnail"><img width="150" height="150" src="http://www.mdislander.com/wp-content/uploads/sites/5/2016/12/paradise-hill-Motor-Road-Bridge-by-George-Soules-1-e1481733055716-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt/></span><p class="yarpp-thumbnail-title"> &#8216;Forgotten&#8217; span view sought</p> </a></li></ul></div></div></div><div class="hide-mobile"><center class="ad-container ad-in-content"><script>!function(e,t,r,n,c,h,o){function a(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return r}try{for(c=e.getElementsByTagName('a'),o='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(h=c[n]).href.indexOf(o))>-1&&(h.href='mailto:'+a(h.href,t+o.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(h=c[n]).parentNode.replaceChild(e.createTextNode(a(h.getAttribute('data-cfemail'),0)),h)}catch(e){}}catch(e){}}(document);</script><script data-cfasync="false" type="text/javascript">broadstreet.zone(40379,{responsive:true});</script></center></div></div></div></div> </article><div class="dcl-disqus-thread" id="comments"><div id="disqus_thread"><div id="dcl-hidden-div" style="text-align: center;"> <button data-disqus-url="http://www.mdislander.com/maine-news/plant-paddle-set" id="dcl_comment_btn" class style="margin-bottom:20px;margin-top:20px;">Load Comments</button></div></div></div> <script type="text/javascript">var disqus_url='http://www.mdislander.com/maine-news/plant-paddle-set';var disqus_identifier='53916 http://www.mdislander.com/?p=53916';var disqus_container_id='disqus_thread';var disqus_domain='disqus.com';var disqus_shortname='mdislander';var disqus_title="Plant paddle set";var disqus_config=function(){var config=this;config.language='';config.callbacks.preData.push(function(){document.getElementById(disqus_container_id).innerHTML='';});};</script> <script type="text/javascript">var DsqLocal={'trackbacks':[],'trackback_url':"http:\/\/www.mdislander.com\/maine-news\/plant-paddle-set\/trackback"};</script> <div class="biz-today horizontal"><aside class="widget widget-zbzdir-list"><h5 class="widget-title zbzdir-title prl-block-title"><a href="http://www.downeastmaine.com">Support Your Local Businesses</a></h5><ul class="zbzdir-biz-list"><li class="zbzdir-biz-listitem"><a class="zbzdir-biz-link" href="http://www.downeastmaine.com?p=2223" data-category="Advertising" data-action="Directory SEM Linkout" data-label="MDI YWCA" data-value="2"><div class="zbzdir-biz" style="background-image: url(http://www.downeastmaine.com/wp-content/uploads/2017/06/ywca-building.jpg);"><div class="zbdir-title">MDI YWCA</div><div class="zbdir-addr">36 Mount Desert Street</div><div class="zbdir-csz">Bar Harbor, ME 04609</div><div class="zbdir-phone">207-288-5008</div></div></a></li><li class="zbzdir-biz-listitem"><a class="zbzdir-biz-link" href="http://www.downeastmaine.com?p=1743" data-category="Advertising" data-action="Directory SEM Linkout" data-label="Woodard Realty" data-value="2"><div class="zbzdir-biz" style="background-image: url(http://www.downeastmaine.com/wp-content/uploads/2015/06/adv1762.jpg);"><div class="zbdir-title">Woodard Realty</div><div class="zbdir-addr">61 Cottage Street</div><div class="zbdir-csz">Bar Harbor, ME 04609</div><div class="zbdir-phone">(207) 288-8181</div></div></a></li><li class="zbzdir-biz-listitem"><a class="zbzdir-biz-link" href="http://www.downeastmaine.com?p=1714" data-category="Advertising" data-action="Directory SEM Linkout" data-label="Keith Trembley Home Solution" data-value="2"><div class="zbzdir-biz" style="background-image: url(http://www.downeastmaine.com/wp-content/uploads/2015/06/keith_trembly.jpg);"><div class="zbdir-title">Keith Trembley Home Solution</div><div class="zbdir-addr">P.O. Box 428, Old Town, Maine 04468</div><div class="zbdir-phone">207-827-4205</div></div></a></li></ul></aside></div> </section><aside id="sidebar" class="prl-span-3"><div id="advanced_menu-2" class="icon-home widget widget_advanced_menu prl-panel clearfix"><h5 class="prl-block-title">News from &#8230;.</h5><div class="menu-towns-container"><ul id="menu-towns" class="menu"><li id="menu-item-1663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1663"><a href="http://www.mdislander.com/bar-harbor">Bar Harbor</a></li><li id="menu-item-1660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1660"><a href="http://www.mdislander.com/mount-desert">Mount Desert</a></li><li id="menu-item-1662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1662"><a href="http://www.mdislander.com/southwest-harbor">Southwest Harbor</a></li><li id="menu-item-1661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1661"><a href="http://www.mdislander.com/tremont">Tremont</a></li><li id="menu-item-2082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2082"><a href="http://www.mdislander.com/trenton">Trenton</a></li><li id="menu-item-2037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2037"><a>Outer Islands</a><ul class="sub-menu"><li id="menu-item-2083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2083"><a href="http://www.mdislander.com/cranberry-isles">Cranberry Isles</a></li><li id="menu-item-2084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2084"><a href="http://www.mdislander.com/frenchboro">Frenchboro</a></li><li id="menu-item-2085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2085"><a href="http://www.mdislander.com/swans-island">Swan&#8217;s Island</a></li></ul></li></ul></div></div><div id="text-8" class="widget widget_text prl-panel clearfix"><div class="textwidget"><div class="eia-right-rail"><script data-cfasync="false" type="text/javascript">broadstreet.zone(58960,{responsive:true});</script></div></div></div></aside></div></div><footer id="footer"><div class="footer-widget"><div class="prl-container"><div class="prl-grid prl-grid-divider"><div class="prl-span-3"><div id="text-11" class="widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Our Websites</h5><div class="textwidget"><center><a href="//www.ellsworthamerican.com">EllsworthAmerican.com</a></center><center><a href="//www.mdislander.com">MDIslander.com</a></center><center><a href="//www.ellsworthamericaninc.com">About Us</a></center><center><a href="//www.reachdowneast.com/calendar">Calendar</a></center><center><a href="//www.downeastmaine.com/">Business Directory</a></center><center><a href="https://www.facebook.com/hchelpwanted" target="_blank">Help Wanted</a></center><center><a href="https://www.facebook.com/HancockCountyRentals" target="_blank">Rental Listings</a></center><center><a href="//www.reachdowneast.com/homeseller">Real Estate</a></center><center><a href="//ellsworthamerican.smugmug.com/The-Ellsworth-American" target="_blank">View & Purchase Photos</a></center></div></div></div><div class="prl-span-3"><div id="text-12" class="widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Send Us Your&#8230;</h5><div class="textwidget"><center><a href="http://www.ellsworthamericaninc.com/submit-a-wedding-engagement-or-anniversary/">Submit a wedding or engagement</a></center><center><a href="//www.ellsworthamericaninc.com/obituaries/">Submit an obituary</a></center><center><a href="http://www.ellsworthamericaninc.com/submit-a-photo/">Submit a photo</a></center><center><a href="http://www.ellsworthamericaninc.com/submit-news/">Submit news</a></center><center><a href="http://www.reachdowneast.com/calendar/events/community/add">Submit a calendar event</a></center><center><a href="https://classadz.vdata.com/Ellsworth/UserType.aspx" target="_blank">Submit a classified ad</a></center></div></div></div><div class="prl-span-3"><div id="text-13" class="widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Contact</h5><div class="textwidget"><center><a href="http://www.ellsworthamericaninc.com/contact-us/contact-advertising/">Advertising</a></center><center><a href="http://www.ellsworthamericaninc.com/contact-us/contact-the-ellsworth-american-newsroom/">American News</a></center><center><a href="http://www.ellsworthamericaninc.com/contact-us/contact-mount-desert-islander-newsroom/">Islander News</a></center><center><a href="http://www.ellsworthamericaninc.com/contact-us/contact-subscriptions/">Circulation</a></center><center><a href="http://www.ellsworthamericaninc.com/contact-us/contact-accounting/">Accounting</a></center><center><a href="http://www.ellsworthamericaninc.com/contact-us/contact-internet/">Internet Services</a></center><center><a href="http://www.mdislander.com/reporters-editors">News Team</a></center><center><a href="http://www.ellsworthamericaninc.com/contact-us/mount-desert-islander-letter-to-the-editor/">Letters to the Editor</a></center><center><a href="http://www.mdislander.com/contact-us">Contact Us</a></center></div></div></div><div class="prl-span-3"><div id="text-14" class="widget widget_text prl-panel clearfix"><h5 class="prl-block-title">Subscriptions</h5><div class="textwidget"><center><a href="http://digital.ellsworthamerican.com/">Access your Ellsworth American digital
edition</a><br> &nbsp;</center><center><a href="http://digital.mdislander.com/">Access your Mount Desert Islander digital
edition</a><br> &nbsp;</center><center><a href="http://www.mdislander.com/subscriptions/">Subscribe or Renew</a><br> &nbsp;</center> <br/><a onclick="ta_openEedition()" href="http://digital.mdislander.com/">.</a></div></div></div></div></div></div><div class="copyright"><div class="prl-container"><div class="left"> &copy; 2017 by <a href="http://www.mdislander.com">Mount Desert Islander</a> - All rights reserved. | <a href="http://www.ellsworthamericaninc.com/privacy-policy/">Privacy Policy</a> | <a href="http://www.ellsworthamericaninc.com/terms-of-use/">Terms Of Use</a></div><div class="right">A <a href="http://www.reachmaine.com">Reach Maine Marketing</a> Production</div></div></div> </footer></div> <a id="toTop" href="#"><i class="fa fa-long-arrow-up"></i></a> <script data-cfasync="false" type="text/javascript" src="http://mountdesertislander.me.pw.newsmemory.com/include.php"></script> <script type="text/javascript">var disqus_shortname='mdislander';(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}
else{url=url[1];}
nodes[i].parentNode.href=url+'#disqus_thread';}}
var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());</script> <script type="text/javascript">var ubermenu_data={"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"959","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","collapse_after_scroll":"on","v":"3.2.5","configurations":["main"],"ajax_url":"http:\/\/www.mdislander.com\/wp-admin\/admin-ajax.php","plugin_url":"http:\/\/www.mdislander.com\/wp-content\/plugins\/ubermenu\/"};</script> <script type="text/javascript">jQuery(document).ready(function(){jQuery('body').fitVids();});</script><script type="text/javascript">var disqus_shortname="mdislander";if(typeof ds_loaded=="undefined"){var ds_loaded=false;}
function loadDisqus(){var disqus_div=document.getElementById("disqus_thread");var top=disqus_div.offsetTop;var disqus_data=disqus_div.dataset;if(!ds_loaded&&(window.scrollY||window.pageYOffset)+window.innerHeight>top){ds_loaded=true;for(var key in disqus_data){if(key.substr(0,6)=="disqus"){window["disqus_"+key.replace("disqus","").toLowerCase()]=disqus_data[key];}}
var dsq=document.createElement("script");dsq.type="text/javascript";dsq.async=true;dsq.src="http://"+window.disqus_shortname+".disqus.com/embed.js";if(document.getElementById("dcl-hidden-div")){document.getElementById("dcl-hidden-div").innerHTML="Loading...";}
(document.getElementsByTagName("head")[0]||document.getElementsByTagName("body")[0]).appendChild(dsq);}}
document.getElementById("dcl_comment_btn").onclick=function(){loadDisqus()};</script><script type="text/javascript">var hash=window.location.hash;var disqus_shortname='mdislander';if(hash!==''){var ds_loaded=true;var dcl_loaded=1;(function(){var dsq=document.createElement('script');dsq.type='text/javascript';dsq.async=true;dsq.src='//'+disqus_shortname+'.'+'disqus.com'+'/'+'embed'+'.js'+'?pname=wordpress&pver=2.84';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(dsq);})();}</script><script src="http://www.mdislander.com/wp-content/cache/min/5/a7c9e904289b918a730b0f9c6ad665fe.js" data-minify="1"></script><script src="http://maps.googleapis.com/maps/api/js" data-minify="1"></script><script src="http://www.mdislander.com/wp-content/cache/min/5/f028553d5cf042cec9e9b8ac72583112.js" data-minify="1"></script> </body></html>
